SPEEDIOユーザー向け
よくあるご質問

SPEEDIOをご利用中のお客様向けに、トラブル対応やメンテナンス、
操作、プログラミングに関するよくあるご質問を掲載しています。

カテゴリから探す

rec-001

RシリーズMシリーズZ軸ジャバラカバー交換手順

RM系Z軸ジャバラカバー交換手順を掲載します。交換時にご活用ください。

詳しくはこちら(PDF 1.4MB)PDFのアイコン

rec-002

SシリーズY軸テレスコカバー交換手順

Y軸テレスコカバー交換手順を掲載します。交換時にご活用ください。

詳しくはこちら(PDF 1.1MB)PDFのアイコン

rec-003

C00 表示灯交換手順

表示灯交換手順を掲載します。交換時にご活用ください。

詳しくはこちら(PDF 1.9MB)PDFのアイコン

rec-004

RシリーズQTクランプセンサ交換手順

QTクランプセンサ交換を掲載します。交換時にご活用ください。

詳しくはこちら(PDF 2.2MB)PDFのアイコン

mt-001

手動グリスアップの方法

手動グリスアップの方法を掲載します。

機械の潤滑油点検とグリスアップは、摩擦による消耗を防ぎ、加工精度と寿命を維持するために必要です。
手動グリスアップは、機械据付後100kmごと、または3ヶ月・実働500時間のいずれか短い期間を目安に行います。

グリス補給後は各軸を全ストロークで動かし、グリスをなじませます。
作業時は怪我防止のためヘルメットや手袋など保護具を着用してください。
グリス補給箇所は各軸(X・Y・Z)にリニアガイド4か所、ボールネジ1か所の計5か所です。

詳しくはこちら(PDF 1.1MB)PDFのアイコン

mt-002

Sシリーズ_テレスコカバーワイパー部品一覧

テレスコカバーのワイパー部品を一覧にて掲載します。

詳しくはこちら(PDF 1.8MB)PDFのアイコン

mt-003

B00制御用全データ出力方法手順

B00制御における全データ出力方法です。日ごろのメンテナンスにご利用ください。

  1. NC電源スイッチを押してNC電源をONにします。
  2. USBメモリを下から斜めにしっかり挿し込みます。
  3. 「プログラム編集」キーを押し、「外部入出力」(F3)→「保守」(F3)と進みます。
  4. 必要に応じて「ディスクフォーマット」を選択し、フォーマット(F2)を実行します。
    (USB内に同形式データが無い・容量に空きが十分ある場合は不要)
  5. ひとつ前の画面に戻り(F0)、「全データ出力」(F1)→「出力」(F2)を選択します。
  6. データ出力が完了するまで操作せず待ち、正常終了を確認します。
  7. 「リセット」キーで手動条件画面に移行し、USBメモリを斜め下に引いて取り外します。
  8. USBメモリをパソコンに接続し、データが保存されていることを確認します。
  9. データは「機械毎のフォルダを作ってパソコンに保管」または「機械専用USBとして保管」します。

作業目安時間は約10分です。

詳しくはこちら(PDF 1.3MB)PDFのアイコン

mt-004

C00制御用全データ出力方法手順

C00制御における全データ出力方法です。日ごろのメンテナンスにご利用ください。

  1. NC電源スイッチを押してNC電源をONにします。
  2. USBメモリを下から斜めにしっかり挿し込みます。
  3. 「プログラム編集」キーを押し、「外部入出力」(F3)→「保守」(F3)と進みます。
  4. 必要に応じて「ディスクフォーマット」を選択し、フォーマット(F2)を実行します。
    (USBに同形式データが無い・容量に空きがある場合は不要)
  5. ひとつ前の画面に戻り(F0)、全データ出力(F1)→出力(F2)を選択します。
  6. データ出力が完了するまで操作せず待ち、正常終了画面を確認します。
  7. 「リセット」ボタンで手動条件画面に移行し、USBメモリを斜め下に引いて取り外します。
  8. USBをパソコンに接続し、データが保存されていることを確認します。
  9. データは「機械ごとのフォルダでパソコンに保管」または「機械専用USBとして保管」します。

作業目安時間は約10分です。

詳しくはこちら(PDF 1.4MB)PDFのアイコン

mt-005

ミストセパレータ内フィルター交換手順

ミストセパレータ内のフィルター点検及び交換方法です。

  1. バルブをひねってエアー圧を切ります。
    エアー圧を切らずに分解すると内圧でエアーが噴き出すため危険です。【電源投入禁止】【エアー切】
  2. M5六角穴付ボルト4本を外し、ミストセパレータを分解します。【手袋着用作業】
  3. 蓋の裏のパッキン2種類に破損や劣化があれば、新品に交換します。
    破損したまま使用するとエアー漏れや機械故障の原因になります。
  4. フィルターを取り出し、新品と交換します。
    変色や硬化している場合も必ず交換し、穴が開いている方向を上にして入れます。
  5. 窓部を手前側に向けて組み付け、M5六角穴付ボルト4本で取り付けます。締付けトルクは6.86N・mです。
詳しくはこちら(PDF 0.8MB)PDFのアイコン

mt-006

Sシリーズ共通_毎日・毎月点検

mt-007

Rシリーズ共通_毎日・毎月点検

mt-008

Mシリーズ共通_毎日・毎月点検

mt-009

D00全データ入力手順

D00制御における全データ「入力」方法です。日ごろのメンテナンスにご利用ください。

USBメモリを操作パネルに取り付けて全データ保守の設定・入力を行い、作業後にUSBメモリを外して電源再投入と動作確認を実施します。

詳しくはこちら(PDF 2.1MB)PDFのアイコン

mt-010

サクションフィルター交換手順

サクションフィルターのフィルター交換方法です。

詳しくはこちら(PDF 1.2MB)PDFのアイコン

mt-011

絶縁抵抗計測定手順

絶縁抵抗計測定方法を掲載します。

詳しくはこちら(PDF 1.6MB)PDFのアイコン

mt-012

Mシリーズチップコンベア、クーラントタンク清掃手順

チップコンベア、クーラントタンク清掃手順を掲載します。日ごろのメンテナンスにご利用ください。

ヒンジスクレーパータイプのチップコンベアは、ヒンジとスクレーパで切粉を分別回収し、PDフィルタや各種フィルタの目詰まり防止・清掃が重要です。
切粉やフィルタの清掃、クーラントタンクの点検・清掃を定期的に行うことで、機械のトラブルを防止します。

詳しくはこちら(PDF 1.2MB)PDFのアイコン

通信のトラブル

c-001

メモリカード側にプログラムが表示されない

プログラム詳細(外部入出力)画面においてメモリカード側の内容に問題がある場合は、下記を確認してください。

画面のメモリカード側の表示内容を確認してください。
プログラム詳細(外部入出力) 画面

正常時の表示

症状1

ファイルが数字4桁表示になっていない
(※CNC-C00)

プログラム詳細(外部入出力) 画面/メモリカード側
  • ※このモードでも入力することは可能ですが、番号のみで入力する方法について記載します
対策

表示方法を変更します

プログラム詳細(外部入出力) 画面

□内を押してください

プログラム詳細(外部入出力) 画面

NC専用ファイルを表示

症状2

ファイルが表示されない
 

プログラム詳細(外部入出力) 画面/メモリカード側
対策

ファイル名を変更してください

O????.NC
  1. ①アルファベットの「O」(オー)
  2. ②0001~8999の4桁の数字 (例)123➝0123
  3. ③拡張子は「NC」
補足 プログラム詳細(外部入出力)画面までの操作手順
手動条件 画面

①プログラム編集キーを押す

プログラム編集メニュー 画面

②F3(外部入出力)キーを押す

外部入出力メニュー 画面

③F1(プログラム)キーを押す

プログラム詳細(外部入出力) 画面

④プログラム詳細(外部入出力)画面

PDFで見る(PDF 0.9MB)PDFのアイコン

c-002

通信フォーマットエラー(ヘッダ/フッタ)が発生する

入力するプログラムとパラメータ設定があっていません。パラメータの設定を行ってください

入力するプログラムの形式によりパラメータを切り替えてください
プログラムの先頭と末尾に"%"が無い

G90 G54 G80 G17
・
・
・
・
・
M30

ヘッダ/フッタを「0:無し」に設定

プログラムの先頭と末尾に"%"が有る

%
G90 G54 G80 G17
・
・
・
・
・
M30
%

ヘッダ/フッタを「1:有り」に設定

【設定画面】
<CNC-C00>
メモリカード 画面

メモリカードの通信パラメータ(ヘッダ/フッタ)を選択 

<CNC-D00>
メモリカード 画面

メモリカードの通信パラメータ(ヘッダ/フッタ)を選択 

補足 メモリカードの通信パラメータまでの手順
<CNC-C00>
手動条件 画面
  1. ①データバンクキーを押す
データバンクメニュー 画面
  1. ②F6(通信パラメータ)キーを押す
シリアルボード 画面
  1. ③F3(メモリカード)キーを押す
メモリカード 画面
  1. ④メモリカードの通信パラメータ画面
<CNC-D00>
データバンクメニュー 画面
  1. ①データバンク → 通信パラメータを選択
メモリカード 画面
  1. ②メモリカードを選択
PDFで見る(PDF 0.8MB)PDFのアイコン

c-003

パソコンで編集したプログラムを入力すると日本語が文字化けする

パソコンで作成したプログラムの文字コードがあっていません。文字コードを修正します。

メモ帳でファイルを保存する時の文字コードをANSIに設定してください。
<CNC-C00>
PC/名前をつけて保存 画面(文字コード)

「UTF-8」➝「ANSI」を選択してください。
(Windows10はデフォルトでUTF-8となっています)

PDFで見る(PDF 0.1MB)PDFのアイコン

c-004

古い機種の対話データを入力したい

対話言語のデータは特殊な形式で、異なるバージョンのNC装置では入力出来ない場合があります。
異なる機種間の対話言語データの互換表
転送元\転送先 TO-211,212,221,215,225 TC-217,227,228,229,311,312,323,324 TC-20A,S2A,S2B,22A,31A,32A,R2A TC-20B,S2C,S2D(N),22B,R2B,31B,32B(N) S300X1,S500X1,S700X1,S300X2,S500X2,S700X2,S1000X1,F600X1,R450X1,R650X1,R450X2.R650X2
TC-211,212,221,215,225 可 不可 不可 不可 不可
TC-321,201,203,217,218,227,228,229,311,312,323,324 不可 可 可 可 可
TC-20A,S2A,S2B,22A,31A,32A,R2A 不可 不可 可 可 可
TC-20B,S2C,S2D(N),22B,R2B,31B,32B(N) 不可 不可 不可 可 可
S300X1,S500X1,S700X1,S300X2,S500X2,S700X2,S1000X1,F600X1,R450X1,R650X1,R450X2,R650X2 不可 不可 不可 不可 可
対話言語の転送について

基本的に古い機種の対話言語はその機種以降に開発された機種に入力することが可能
(TC-211~TC-225の機種は対応できていません)
新しい機種の対話言語を、その機種以前のNC装置に入力することはできません。

TC-211~TC-225の機種について

当時の記憶装置はバブルカセットで、他の通信方法がありません。このため他の機種にプログラムを移行することが出来ません

TC-217~現行機種

オプションで通信機器が設定でき、Rc232cが使用できます。Rc232cの記憶装置 を使用することで、対話言語の移行が可能です。

PDFで見る(PDF 0.1MB)PDFのアイコン

c-005

IPアドレスが入力できない

IPアドレスの数値入力方法が違っています。正しい入力方法で、設定してください。

  1. イーサネット/FTP画面に移行し、カーソルを「IPアドレス」に合わせます。
  2. 入力窓にIPアドレスを入力し設定キーを押します。

入力窓に記述するときは、ピリオド無しで12桁を入力します。
(例)192.168.12.3を設定したい場合、 192168012003

<CNC-C00>

イーサネット/FTP 画面

<CNC-D00>

イーサネット/FTP 画面
補足 イーサネット/FTP画面までの操作手順
<CNC-C00>
手動条件 画面

①データバンクキーを押す

データバンクメニュー 画面

②F6(通信パラメータ)キーを押す

シリアルポート 画面

③F2(イーサネット/FTP)キーを押す

イーサネット/FTP 画面

④イーサネット/FTP画面

<CNC-D00>
データバンクメニュー 画面

①データバンク → 通信パラメータを選択

イーサネット/FTP 画面

②イーサネット/FTPを選択

PDFで見る(PDF 0.8MB)PDFのアイコン

c-006

CM7520:無効データ受信エラー発生する

プログラムを機械へ入力するとアラームCM7520:無効データ受信が表示される。
USBからプログラムを入力するとCM7520:無効データ受信が表示される。

機械がサポートしていない文字がプログラムに含まれていると発生します。
サポートしていない文字を消去したプログラムを入力してください。
プログラムが長い、分からないといった場合は以下を変更してください。

ユーザパラメータ/6.通信パラメータ

以下より通信方法を選択します。

  • F1キー(シリアルポート)
  • F2キー(イーサネット/FTP)
  • F3キー(メモリカード)
  • ※メモリカードはUSBのことも指します。
無効データ [0:変換 1:エラー 2:無視]を1:エラー以外に変更して下さい。
0:変換

無効なデータを「?」に変換しプログラムを入力します。
入力したプログラムの無効データ部を「?」に変換します。
入力後「?」を消去して下さい。

2:無視

無効なデータを無視してプログラムを入力します。

  • ※無効なデータ以外を入力します。

F3キー(メモリカード)

メモリカード 画面
PDFで見る(PDF 0.1MB)PDFのアイコン

c-007

PCからファイル操作した時に「CM7522 受信コマンド異常終了(0010)」が発生し、ファイルの上書きやフォルダの削除ができない

通信パラメータを確認してください。

「データバンク」→「通信パラメータ」→「イーサネット/FTP」
のメニューで「データ上書き(従局)」を「する」に設定します。

<CNC-C00>

イーサネット/FTP 画面

<CNC-D00>

イーサネット/FTP 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

c-008

PCとLANケーブルで接続したい。コネクタの位置を知りたい

制御BOXを開けて左上のNC基板上にあります。

<CNC-C00>
制御BOX内部

「XLAN」に接続します。

<CNC-D00>
制御BOX内部

「XLAN1」に接続します。

PDFで見る(PDF 0.3MB)PDFのアイコン

c-009

CC-LINKの通信設定をしたい

データバンクで設定します。

<CNC-C00>

「データバンク」 → 「ユーザパラメータ」を選択します。

F7キーの右の「>>」のキーを何度か押すとCc-Linkスレーブのメニューが
表示されるので、その状態でF7を押すと下の設定画面が出ます。

Cc-Linkスレーブ 画面
<CNC-D00>

「データバンク」 → 「フィールドネットワークパラメータ」を選択します。

データバンクメニュー 画面

「CC-LINKスレーブ」を選択します。

フィールドネットワークパラメータ 画面

設定画面が表示されます。

Cc-Linkスレーブ 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

c-010

イーサネットIP用のEDSファイルが欲しい(CNC-D00)

イーサネットIPのオプションに付属のCD-ROMにEDSファイルがあります。
付属のCD-ROMをご確認お願いします。

PDFで見る(PDF 0.1MB)PDFのアイコン

プログラムのトラブル

tr-001

パレチェン機でユーザパラメータ(クイックテーブル)にプログラム番号を登録したがプログラムが変わらない

パレット選択の状態を確認してください。
<CNC-C00>
パレット選択SW
  1. ①パレット選択が「1⇔2」を選択する必要があるので、パレット選択SWを何度か押します。
「1⇔2」のランプが点灯
  1. ②パレット選択が「1⇔2」のランプを点灯させてください。
<CNC-D00>
タッチパネルの下の方にある一番左のアイコン
  1. ①タッチパネルの下の方にある一番左のアイコンをタッチします。
パレット選択のアイコン
  1. ②メニューが切り替わるのでパレット選択のアイコンをタッチします。
パレット選択画面のポップアップ
  1. ③パレット選択画面がポップアップするので「1⇔2」をタッチします。
PDFで見る(PDF 0.2MB)PDFのアイコン

tr-002

穴加工数で工具寿命がカウントしない

  • 穴加工数は穴開けの固定サイクルを使った場合を対象としています。
  • 穴加工数を選択する場合の穴加工は穴開けの固定サイクルを使って下さい。
  • 穴開けの固定サイクルを使わない穴加工は、工具寿命を穴加工数で設定しても寿命の増減は行われません。
<CNC-C00>設定画面
設定画面
  1. ①穴開けの固定サイクルを使って加工すると寿命をカウントします。

穴加工数を選択し、穴開けの固定サイクルを使って加工した穴の寿命は、1穴加工する毎にカウンタが増減します。

寿命のカウント方式はカウントアップ、カウントダウンをユーザパラメータで自由に変更出来ます。

<CNC-D00>設定画面
設定画面
PDFで見る(PDF 0.1MB)PDFのアイコン

tr-003

パレチェン機で選択したプログラムと違うプログラムが起動する

パレット選択状態では選択中のパレットに登録しているプログラムが起動します。
パレット選択キーを「切」に設定して下さい。

パレット選択の切り換えと確認方法(CNC-C00)
  1. ①パレット選択キーでメモリ運転起動時に使用するパレットの選択を切り換えます。
  2. ②選択中のパレットはLEDが光っている位置で判別します。
  3. ③パレット選択キーのLED消灯時が「切」(パレット使用無し)です。
パレット選択キー

パレット選択キー

  • 1が点灯でパレット1を使用
  • 2が点灯でパレット2を使用
  • 1↔2が点灯でパレットを交互に使用
  • LED消灯で「切」(パレット使用無し)
  • ※1→2→1↔2→切(消灯)→1→…とキーを押す度に順にLEDの点灯が変化します。
  1. ①パレット選択が「1⇔2」を選択する必要があるので、パレット選択SWを何度か押します。
パレット選択の切り換えと確認方法(CNC-D00)
タッチパネル
  1. ①タッチパネルの下の方にある一番左のアイコンをタッチします。
メニュー
  1. ②メニューが切り替わるのでパレット選択のアイコンをタッチします。
パレット選択画面のポップアップ
  1. ③パレット選択画面がポップアップするので「切」をタッチします。
パレット選択キー「切」でメモリ運転の開始
  • パレット選択キーを「切」(パレット選択なし)でメモリ運転の開始は起動スイッチで 行います。
  • 外側起動スイッチは無効となるため、外側起動スイッチではメモリ運転は開始出来ません。
  • パレットの入れ換えが必要であれば、メモリ運転開始前に手動で入れ換えて下さい。
PDFで見る(PDF 0.3MB)PDFのアイコン

手動操作のトラブル

tr-004

手動パルサーでC軸が回らない

対象機種M140X*、M200X*、M300X*

旋回主軸選択がONになっています。

操作パネルを確認します。旋回主軸選択がONになっているので、
一旦手動パルサーをOFFして、旋回主軸選択SWを押して旋回主軸選択をOFFにします。

<CNC-C00>

操作パネル

<CNC-D00>

操作パネル
PDFで見る(PDF 0.2MB)PDFのアイコン

エラー発生時の対応

r-001

「ストロークオーバ」が発生したが、ストローク内に軸を動かしたい

軸の位置がストローク以外にずれたため、特殊操作が必要になります。

  1. 【手動運転】キーを押して手動モードに変更
  2. 【リセット】を押してアラームを解除
  3. 機械座標を確認しストローク外に出ている軸を確認する
  4. 【解除】キーを押しながらジョグキーまたは手動パルス発生器で所定の軸をストローク内に戻す

(解除キーの位置)

解除キーの位置

(例)【解除】+【-Z】でZ軸をストローク内に戻す

手動条件 画面
(例)タレット式マガジンの工具交換の途中で機械を止めてしまった場合の復旧方法
Z軸最上点が480.0㎜(標準コラム)
手動条件 画面

Z軸最上点の機械座標値:Z 480.0

標準コラムの場合、Z軸の最上点はZ480.0㎜の位置になります。

工具交換はこの位置より高い、ATC原点で行われるため、工具交換の途中で止めてしまうと、それ以降機械を動かそうとすると「Z軸位置エラー」のアラームが出てしまい機械を動かせません。

「Z軸位置エラー」が発生するZ一例
手動条件 画面

ATC原点の機械座標値:Z615.0

復旧には機械座標位置のZ軸位置を480.0㎜より下げる操作を行います。

Z軸位置が480.0㎜より高い位置では機械は操作を受け付けないため、下記の操作で復旧を行います。

復旧手順
  1. リセットキーを押しアラームを解除します。
  2. 手動運転キーを押します。
  3. 解除キーを押したまま「-Zキー」を押しZ軸を下降させます。
  4. Z軸が機械座標位置で480㎜以下になったら解除キーと「-Zキー」を離します。
  5. リセットキーを押します。
PDFで見る(PDF 0.2MB)PDFのアイコン

r-002

タップ加工で、「指令不可Gコード」(アラーム番号SM4001)が発生する

旋削加工で、周速一定制御G96が有効になっています。G96が有効な時にタップ加工G77を実行すると「指令不可Gコード SM4001が発生します。

アラーム/オペレータメッセージ復旧 画面
  • G96周速一定の加工が終了したらG97周速一定キャンセルを入力してください。
  • タップの工具交換ブロックにG97周速一定キャンセルを入力してください。
    (どちらかの方法でG97をキャンセルします)

参考用プログラム

G54G0G90G17G97G94G98;
G92S2000;
G18G54M8;
G100T1G95X10.0Y0A0G143H1Z30.S2000M142M303;
G96P1S300;(周速一定)※
G0Z0.;
G01X30.0F0.05;
G0Z10.0;
G97;(周速一定キャンセル)※
G17G56;
G100T2G94X0Y-10.A0.C0G43H2Z70.M141 G97;タップ工具の工具交換時に周速一定キャンセル
G77Z-15.0R2.0I1.0S3000; タップ加工
・

  • ※どちらかでOK
PDFで見る(PDF 0.1MB)PDFのアイコン

r-003

メモリ運転で、「マガジンに工具無し」(アラーム番号SM2054)が発生する

選択されたプログラムで使用している工具(工具一覧の工具No)がATCマガジンに登録されていない場合、このエラーが発生します。NC装置は選択されたプログラムで使用する工具を確認し、使用している工具が 全てマガジンに登録してあるかをチェックします。
説明書の復旧方法では「工具一覧に必要な工具を登録」とありますがATC工具登録をしてください。

ATC工具登録とはマガジン番号とT番号の紐づけのことです。
取り付けたマガジン番号へ、取り付けたツールの番号を入力することで完了します。

例としてT31をマガジンの2へ取り付けた場合、マガジン2の工具番号の列へ31と入力します。

ATC工具登録の手順
  1. ①ATC工具(詳細)画面で、F1(工具設定)を押すと、青いカーソルバーが表示されます。
  2. ②カーソルを02行に移動させます。(カーソルキーを使用)
  3. ③水色のカーソル部を工具番号列に移動させます(カーソルキーを使用)
  4. ④中段の工具番号入力枠に「31」を入力して設定「EOB]を押します。

完了するとこの画像の様になります。

ATC工具(詳細)画面

ATC工具(詳細) 画面

注意)

  • ※M30より下の行に工具呼び出しが入っている場合、マガジンに工具番号登録がされていないと同じアラームが発生します。
    対処方法はM30以下をプログラムから消してください。
補足 ATC工具(詳細)画面までの操作手順
手動条件 画面

手動条件画面

①MDI運転キーを押す

MDI運転 画面

MDI運転画面

②ATC工具キーを押す

ATC工具(詳細) 画面

ATC工具(詳細)画面(入力枠有り)

MDI運転モードからATC工具画面に入ると工具番号を設定する入力枠が現れる。

ATC工具(詳細) 画面

ATC工具(詳細)画面(入力枠無し)

MDI運転モード以外からATC工具画面に入ると入力枠が出てこないので注意すること

PDFで見る(PDF 0.4MB)PDFのアイコン

r-004

「SM9***(9000番台)」エラーが発生する。

SM9000番台のエラーはマクロエラーです。
加工プログラムの中で、エラーを作成しているため、加工プログラム作成者に確認が必要です。

操作説明書 11章 アラーム

操作説明書 11章 アラームより

プログラミング説明書 6章 マクロ

プログラミング説明書 6章 マクロより

補足 SM9000番台の対処方法例

このエラーは加工プログラムの作成者がプログラム内でエラーを作成しています。
このため、詳細はプログラム作成者に確認する必要があります。

発生したアラーム番号を確認します。
例) SM9120 ***エラー が発生した場合
プログラム上で #3120=(***エラー) の行を検索します。

この行の上位で、 この行にジャンプする条件文を探します。
例えば

条件文

#3120は この条件文からジャンプしてきます。
エラーの原因は この条件文#100が50になったことです。
この原因を解消する必要があります。

PDFで見る(PDF 0.2MB)PDFのアイコン

r-005

「SM5500 バッテリ交換時期」の表示が発生

サーボモータの位置データを保持するバッテリーが消耗しました。電池の交換が必要です。

重要)以下の電池交換は機械の電源を入れた状態で行ってください

  1. アルカリ乾電池単三 1.5Vを3本用意して下さい。
  2. 下記の場所に有る電池BOXの3本のアルカリ乾電池を全て交換します。
機械後部 制御盤

機械後部 制御盤

アブソリュートエンコーダ側電池ボックス

①アブソリュートエンコーダ側電池ボックス

PDFで見る(PDF 0.3MB)PDFのアイコン

r-006

SM2111:工具主軸回転数エラーが発生する。

対象機種 M140X*、M200X*、M300X*

工具データを確認してください。

工具一覧で設定を確認します。

最高回転数の項目に0が入っているので、これを削除します。

<CNC-C00>

工具一覧(拡張2)

<CNC-D00>

工具一覧(拡張1)
PDFで見る(PDF 0.2MB)PDFのアイコン

r-007

SL7591:サブプログラムなしのエラーが発生する

SL7591:サブプログラムなし(*)のエラーは(*)内の番号のサブプログラムが見つからないため発生するアラームです。

指令したサブプログラムの番号と用意したサブプログラムの番号が一致するか確認して下さい。
サブプログラムとメインプログラムが同じフォルダに有る事を確認して下さい。
マクロ変数を使ってサブプログラム番号を指令する場合、呼び出す可能性のあるサブプログラム番号をM30以降にM98で指令して下さい。

例)変数によりO101、O201、O205が呼び出される可能性があるプログラム

  • M98P#500;
  • M30;
  • M98P101;
  • M98P201;
  • M98P205;
PDFで見る(PDF 0.1MB)PDFのアイコン

r-008

連続してリファレンス点復帰を実行すると、SM2017:ストロークオーバー(+Z)が発生する

連続してレファレンス点復帰を行うとSM2017:ストロークオーバー(+Z)が発生します。
連続してレファレンス点復帰をしなければ良いため、次に呼び出すサブプログラム先頭のレファレンス点復帰を消すかコメント化してください。

サブプログラム1と2を呼び出すメインプログラム

(main)
M98P0001;
M98P0002;
M30;

サブプログラム1

(sub 0001)
G91G28Z0;
G90;
G01Z‐5.0F100;
G01X10.0F500;
G00Z10.0;
G91G28Z0;
G90;

サブプログラム2

(sub 0002)
G91G28Z0;
G90;
G01Z‐5.0F100;
G01X-10.0F500;
G00Z10.0;
G91G28Z0;
G90;

変更

(sub 0002)
(G91G28Z0;)
G90;
G01Z‐5.0F100;
G01X-10.0F500;
G00Z10.0;
G91G28Z0;
G90;
M99;

レファレンス点復帰のブロックをカッコで括りコメントへ変更

PDFで見る(PDF 0.1MB)PDFのアイコン

r-009

SM4006:指令不可数値データエラーが発生する

指令値が数値として正しく入力されていないため発生します。

指令値が数値として正しく入力されているか確認して下さい。

例)入力値を修正したとき小数点を余分に入れている。

G01 X100.0.F1000;

例のような入力は数値として正しくないためアラームが発生します。

PDFで見る(PDF 0.1MB)PDFのアイコン

r-010

SM7513:A軸ロック信号がONしているエラーが発生する

A軸が動く条件に内蔵PLCで制限を掛ける回路が組まれています。

多くのケースはワークの破損/落下防止のため、治具クランプ状態のときにだけ、A軸動作を許可する回路になっています。治具をセットアップされたメーカ様の説明書を確認いただくか下記の方法で内蔵PLC回路を見て、A軸がロックする条件を確認します。

手動条件 画面

①入出力キーを押す

入出力メニュー 画面

②F6(PLC)キーを押す

PLC 画面

③F2(PLC)キーを押す

PLC 画面

④F2(標準ラダープログラム1)キーを押す

標準ラダー1:PLC表示モード 画面

⑤標準ラダー1が表示されたら見やすいようにF2(モニターモード)とF7(コメント表示)を押す

画面左下

⑥F4(検索)キーを押して画面左下に「検索」を表示後「BY015」と入力し「設定」キーを押す

  • ※BY015(A軸ロック信号)がONする条件を検索します。
A軸ロック信号ON 画面

上記は一例ですが、A軸ロック信号は

1:LT11
1:LM209
以上二つの信号がOFFでA軸ロック信号がONします。

⑥の検索手順で調べていくと

標準ラダー1:PLCモニタモード 画面 標準ラダー1:PLCモニタモード 画面

A:LT11のON条件はクランプセンサがONであることがわかります。(※1)
B:LM209のON条件は手動モードかつ解除キー押下であることがわかります。

Bは手動操作の異常解除時に使う特殊操作で通常OFFであることからAがONしていない、
つまりワーククランプセンサがONしていない状態で A軸動作させようとしてエラーが出たことがわかります。

  • ※1 この例ではX010がワーククランプセンサON信号が割り当てられています。

PDFで見る(PDF 0.6MB)PDFのアイコン

r-011

SL7547:該当工具なしが発生する

工具の割り当て 画面

①工具一覧にある工具で割当出来ない

「該当工具なし」は、工程に割当る工具が工具一覧に無い場合発生します。
割当られなかった工程を割当画面で確認してください。
工具番号に■■が入っている工程が「該当工具なし」の対象です。

割当できない原因
  • 工具一覧に登録している工具データに間違いが無いか確認して下さい。
  • プログラムの工程で指定した工具径に間違いが無いか確認して下さい。

間違いが無い場合、登録した工具で加工出来るか以下の手順で確認します。

  1. 割当画面で■■に割当したい工具番号を入力(強制割当と呼びます)
  2. F6キー(工具チェック)を押し、強制割当した工具で割当出来ない原因を調べます。
工具の割り当て 画面

①割当出来ない原因

②10番を強制割当

F6キー(工具チェック)を押すとアラーム形式で割当出来ない原因を表示します。

上図では工具番号10の工具で加工データ通りの動作をしたとすると、工具番号10に入力された刃長では「刃長が短い」ため加工データ通りの穴深さに加工出来ないと判断してます。

工具データもしくは加工データを修正後、上記の方法でもう一度確認します。
問題なければF7キー(工具割当)を押して座標値を再計算して完了です。

工具チェックで切削条件の工具と違うと表示された場合
工具の割り当て 画面

「切削条件の工具と違う」はプログラム編集メニューの「4.切削条件」のことでは無く、加工データの工程で指定した工具のことを示しています。
この画面の場合、強制割当した「工具一覧の工具番号2の工具径」と、加工データで指定した工具径が合っていません。
加工データで指定した工具径、工具一覧に登録した工具径のどちらが正であるかを確認して間違っている方を修正すれば割当が出来ます。

PDFで見る(PDF 0.2MB)PDFのアイコン

r-012

IO2026:CTS降圧していないを解除したい

このアラームはクーラントによる配管内の圧力異常が原因で発生します。
配管内に溜まったクーラントを排出する必要があります。
CTS非対応の工具/ホルダが原因でクーラントが溜っている場合、簡単な解決方法として工具交換をすることで排出を行います。
アラームが発生した状態では機械を動作出来ないため、一時的にユーザパラメータの一部を変更します。

以下の手順はアラームを解除して機械を操作出来る状態にするための手順です。
根本的な対処方法ではないため、アラーム解除後はアラームが発生した原因を突き止め対処して下さい。

操作パネルのキー配置
操作パネル
  1. ①データバンクキー
  2. ②EOBキー
  3. ③カーソルキー
  4. ④ページキー

以下の手順でユーザパラメータを変更します。

  1. データバンクキーを押して下さい。
  2. F4キー(ユーザパラメータ)を押して下さい。
  3. F1キー(スイッチ1)を押して下さい。
  4. 0138 CTS降圧確認遅延時間の値をメモして下さい。
  5. 0138 CTS降圧確認遅延時間の値を0へ変更します。

    変更手順

    • 0138 CTS降圧確認遅延時間へカーソルを合わせます。
    • 次に操作パネルの数値キーで0を入力して下さい。
    • 次に操作パネルの;EOB/設定キーを押して下さい。
    • 次にF0キー(終了モード)を押して下さい。
    • 次にF0キー(編集終了)を押して下さい。
  6. リセットキーを押して下さい。

以上の手順でアラームを解除し、手動運転モードで工具交換をしてください。

変更手順1

4.ユーザパラメータを選択、EOBキーを押す または、F4キー(ユーザパラメータ)を押します。
変わった画面でF1キーを押します。

データバンクメニュー 画面

データバンクキーを押した際の画面

変更手順2-5

ページキー↓で138にカーソルを合わせます。
元の値をメモしてください。
メモしたら0を入力します。
EOBキーを押します。
F0キー(終了モード)を押します。
F0キー(編集終了)を押します。
元に戻す場合は0138へメモした値を入力し、EOBキーを押し、F0キーを2回押します。

スイッチ1 画面

F1キー(スイッチ1)の画面

工具交換を終えたら先ほど変更した0138 CTS降圧確認遅延時間の値をメモした値に戻し操作完了となります。

元の値へ戻す変更手順
  1. データバンクキーを押して下さい。
  2. F4キー(ユーザパラメータ)を押して下さい。
  3. F1キー(スイッチ1)を押して下さい。
  4. 0138 CTS降圧確認遅延時間をメモした値へ変更します。

    変更手順

    • 0138 CTS降圧確認遅延時間へカーソルを合わせます。
    • 次に操作パネルの数値キーでメモした値を入力して下さい。
    • 次に操作パネルの;EOB/設定キーを押して下さい。
    • 次にF0キー(終了モード)を押して下さい。
    • 次にF0キー(編集終了)を押して下さい。

以上で元の値へ変更完了です。

PDFで見る(PDF 0.3MB)PDFのアイコン

r-013

同期タップ戻し機能の無い機械でタップ復旧動作をしたい

MDI運転でプログラムを入力し実行します。
同期タップ戻しのプログラム

タップ戻しのプログラムは、ねじれ方向切り換えG133(正転)/G134(逆転)を使います。
右ねじのタップ戻しはG134です。

プログラム例(右ねじ)

G134 Z_I_(J_)S_と入力します。

  1. Z:Z軸目標位置
  2. I:ねじピッチ(メートルねじはこちらを使います)
  3. J:山数(インチねじはこちらを使います)
  4. S:主軸回転数
  • ※同期タップなので、Z軸と主軸が同期して動きます。
同期タップ戻しのプログラム作成の考え方
  1. 停止したZ軸位置からタップが抜けきる距離をZで入力します。
    抜けきる必要があるため距離は少し長めにします。
  2. ねじのピッチまたは山数を確認します。
    メートルねじはピッチをIで、インチねじは山数をJで入力します。
  3. 回転数を決めます。
    タップを抜く回転数をSで入力します。
  4. プログラムはG91(インクレメンタル)で動作させます。
プログラム作成例(右ねじ)
  1. タップが抜けきる距離を30.0とします。
  2. メートルねじでピッチを1.0とします。
  3. 回転数を500とします。

G91 G134 Z30.0 I1.0 S500

  • ※MDI運転で上記を入力、実行すると停止した位置からタップが逆回転しながら30.0mm上昇します。
プログラムの動作イメージ
プログラムの動作イメージ
  • ①停止した位置から30.0mm上昇した位置
  • ②停止した位置
PDFで見る(PDF 0.1MB)PDFのアイコン

ファイル操作

file-001

工具データをUSBへ出力したい。

USBを本機へ接続後に下記操作で出力します。

  1. プログラム編集キーを押します。
  2. F3キー(3.外部入出力)を押します。
  3. F2キー(2.データバンク)を押します。
  4. 青く反転しているカーソルを工具データに合わせます。
  5. 現在使用中のデータを出力する場合は背景色が緑色の番号を入力します。
  6. F2キー(出力)を押します。
  • ※現在使用中以外のデータを出力する場合は出力する番号を入力して下さい。

3.の操作で画面右側がメモリカード側と表示されない場合は接続先切り換えをして下さい。

  1. 3.の操作後、≫キーを押しメニューを切り換えます。
  2. F1キー(接続先切り換え)を押します。
  3. 2を入力してEOBキーを押します。
  4. F0キー(戻る)を押し前の画面へ戻ります。
    以降はUSBへ出力する操作の4.から始めて下さい。
データバンク(外部入出力) 画面
  • 番号入力後、F2キー(出力)で画面のNC側からメモリカード側へ選択した項目の番号のデータがメモリカード側へ出力されます。
  • コピーして出力されるためNC側に元データが残ります。
  • 緑色に反転している番号が現在使用中のデータバンク番号です。
  • 画像では1番が緑色になっており使用していることが分かります
  • 1番を出力するなら1を入力してからF2キー(出力)を押します。
  • 出力すると画面のメモリカード側に1番が現れます。
PDFで見る(PDF 0.1MB)PDFのアイコン

file-002

USBからプログラムをコピーしたい

プログラム編集モードで実施します。

USBを本機へ接続後に下記操作で出力します。

モードで「プログラム編集」を選択し、「3.外部入出力」→「1.プログラム」を選択します。

「F7:カーソル左右切替」でNC側/メモリーカード側の選択が切り替わります。
コピーしたいプログラムのフォルダにそれぞれカーソルキーで移動させます。
NC側/メモリーカード側共にフォルダ移動が完了したら、カーソルをメモリーカード側に合わせて「F3:プログラム選択」を押します。

プログラム詳細(外部入出力) 画面

プログラム選択を押すとメニューが切り替わるので、入力したプログラムにカーソルを合わせて、入力したいプログラムを選択します。選択されたプログラム番号は太字に変わります。

プログラム詳細(外部入出力) 画面

プログラム選択が完了したら、「F0:戻る」を押してメニュー画面に戻します。
プログラムが選択された状態であることを確認して「F4:入力」を押します。

プログラム詳細(外部入出力) 画面

入力が完了すると、下記のようにNC側にプログラムが追加されます。

プログラム詳細(外部入出力) 画面
PDFで見る(PDF 0.6MB)PDFのアイコン

file-003

プログラムのコピー/削除をしたい

プログラム編集モードで実施します。

モードで「プログラム編集」を選択し、プログラム編集メニューで「ディレクトリ表示」を選択します。
コピー/削除したいプログラムがあるフォルダに移動させます。

ディレクトリ表示 プログラム 画面
【プログラムをコピーしたい場合】

「プログラム番号」に(コピー元のプログラム番号)ー(コピーしたいプログラム番号)を入力します。
例えば今ある100番のプログラムを300番にコピーしたい場合
100-300
と入力し「F4:コピー/チェック」を押すと100番のプログラムが300番にコピーされます。

【プログラムを削除したい場合】

1個のプログラムを削除したい場合

削除したいプログラム番号にカーソルを合わせて「F5:削除」を押します。
削除しても良いですか?とメッセージが出るので削除する場合は「F0:はい」を押します。

複数プログラムを削除したい場合

「プログラム番号」に(削除したい先頭のプログラム番号)/(削除したい最後のプログラム番号)
を入力します。例えば200番~210番まで一括削除したい場合
200/210
と入力し「F5:削除」を押すと以下の確認メッセージに変わります。
1プログラムずつ確認しながら削除する場合は「F0」、一括削除する場合は「F4」をそれぞれ押します。

確認メッセージが表示された画面
PDFで見る(PDF 0.3MB)PDFのアイコン

file-004

フォルダの削除をしたい(CNC-C00)

以下の手順で行います。

「プログラム編集」→「2.ディレクトリ表示」で以下の画面を表示させて、フォルダ一覧画面が出るようにします。

ディレクトリ表示 プログラム詳細 画面

フォルダ一覧画面が表示出来たら、F7の右横の「>>」のキーを押して
ファンクションキーの上の表示を切り替えます。

ディレクトリ表示 プログラム詳細 画面

表示が切り替わったら「F2:フォルダ間操作」を押します。

ディレクトリ表示 フォルダ間操作詳細 画面

フォルダ間操作を押すと↑に画面が切り替わります。
「F6:フォルダ操作」を押します。

ディレクトリ表示 フォルダ操作詳細 画面

フォルダ操作を押すと↑の画面に切り替わるので、削除したいフォルダをカーソルで選択し「F4:削除」を押します。
(上記例では「BCUT」というフォルダを削除します)

ディレクトリ表示 フォルダ削除詳細 画面

削除しても良いか確認メッセージが出るので、はいを選択して削除します。

PDFで見る(PDF 0.4MB)PDFのアイコン

NCプログラミング

ncp-001

NCプログラムで現在パレット1か2が機内にあるか判別したい(Rシリーズ)

マクロ変数のシステム変数を参照することで判別できます。

マクロ変数表

#5024がパレットの現在位置になります。

具体的な数値は以下になります。

-180.150 → パレット1

0.150 → パレット2

PDFで見る(PDF 0.2MB)PDFのアイコン

ncp-002

プログラムを実行するとワーク座標原点の値が変わってしまう

G10もしくはマクロのシステム変数でワーク座標を書き換えていませんか?

1.G10でのワーク座標の書き換え

下記の通り
G10L2P…でG54~G59のワーク座標原点を書き換えます。
G10L20P…でG54.1P1~G54.1P48のワーク座標原点を書き換えます。
これらのGコードがプログラム中に入っていないかを確認します。

3.6.1 ワーク座標原点データの入力
3.6.6 追加ワーク座標原点データの入力
2.マクロのシステム変数を用いてのワーク座標の書き換え

下記の通りマクロのシステム変数にワーク座標原点が割り当てられていて書き換え可能です。
プログラム中に該当するマクロ変数があるかどうか確認します。

6.2.6.2 ワーク座標原点
PDFで見る(PDF 0.2MB)PDFのアイコン

ncp-003

ワーク座標原点を「G54-G59」の6カ所以上に設定したい

拡張ワーク座標系(G54.1P1~G54.1P48)が48個使用できます。

【データバンクで設定】

「データバンク」→「ワーク座標原点」で以下を表示させます。

ワーク座標原点 画面
  1. ①「F1:拡張座標」を押すことで拡張座標系に切り替わります。
ワーク座標原点(拡張) 画面
  1. ②「F1:拡張座標」を押すことで通常座標系に切り替わります。

拡張ワーク座標原点を使用する場合は以下のGコードで指令します。

指令形式
【プログラマブル原点入力(G10)で拡張ワーク座標系を設定】

以下の形式で指定可能です。

拡張ワーク座標原点を使用する場合は以下のGコードで指令します。

指令形式
PDFで見る(PDF 0.4MB)PDFのアイコン

ncp-004

外部座標原点オフセット機能を使いたい(CNC-C00)

  • ※<CNC-D00>に関しては下記方法以外にパラメータで設定可能です。
  • ※詳しくは<CNC-D00>の外部座標オフセットのページを参照してください。

以下のいずれかの方法で実施します。

①内蔵PLCの変更で対応
ラダー図

BY0D6(EXWORK)のコイルをONすることで、外部ワーク座標オフセットが有効になります。
このラダー図は常時EXWORKがONになる仕様ですが、ONになる条件を記述することにより条件に応じてEXWORKをONさせることが可能です。

  • PLCの編集方法はPLCシステム説明書を参照してください。
②I/O基板の配線で対応

汎用I/Oに割り付けて外部ワーク座標オフセット有効にします。

「データバンク」→「5:外部入出力信号」→「F1:外部入力信号」で画像の画面が表示されます。
空いている入力端子台の入力に「509」を入力します。入力すると該当する端子番号の信号名に「EXWORK」と表示されます。

設定した端子番号に入力信号がONするように配線を行います。

外部入力信号 画面
  • ※配線に関しては「設置説明書:第五章 外部入出力信号」を参照し実施してください。
  • ※配線作業は電気の知識がある人が実施してください。
PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-005

工具長測定プログラムを自作したが、Z座標位置の測定結果がばらつく

測定プログラムのマクロ変数を確認してください。

G31でツールセッターに接触後の読み取り座標を#5023(現在位置 Z)を使用していませんか?
#5023では読み取るタイミングで値がばらつきます。
工具長測定時はG31の命令後は#5063(スキップ座標 Z)で読み取ります。
これにより、読み取りタイミングに関わらず安定した値になります。

6.2.6.10 現在位置
PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-006

クーラントがオフのとき、加工プログラムを起動しないようにしたい(CNC-C00)

内蔵PLCとマクロを組み合わせることで実現可能です。

下記に内蔵PLCとマクロを組み合わせた例を示します。

【内蔵PLC】

クーラント(もしくはクーラントSW)がONしたときにマクロ変数がONする回路を組みます。
下記例はマクロ変数#1000を使っていますが任意の変数でOKです。

回路の組み方 例
【NCプログラム】

(O1001)
IF[#1000 EQ 1] GOTO 1000
(アラーム処理)
#3000=1(COOLANT ERR) ←クーラントがOFFの場合はアラーム停止させる
N1000
(通常処理)
M30

  • ※CNC-D00に関してはユーザパラメータの設定で起動前チェックが可能です。
  • ※詳しくは「データバンク、アラーム説明書」をご覧ください。
PDFで見る(PDF 0.2MB)PDFのアイコン

ncp-007

外部ワーク座標原点オフセットを使いたい(CNC-D00)

パラメータの設定で方式を選択して使用します。

「データバンク」→「ユーザパラメータ」→「スイッチ1」で「運転」のタブを選択します。

スイッチ1(運転) 画面

方式1を設定すると、外部座標系シフト有効信号によって外部ワーク座標系シフト量の有効無効状態を切り替えます。

  • ※信号の設定切替方法は次ページを参照してください

方式2を設定すると、外部座標系シフト有効信号に関わらず常時外部ワーク座標系シフト量が有効になります。

外部座標系シフト量の信号を有効にする方法は下記の2通りの方法があります。

①内蔵PLCの変更で対応
ラダー図

BY0D6(EXWORK)のコイルをONすることで、外部ワーク座標オフセットが有効になります。
このラダー図は常時EXWORKがONになる仕様ですが、ONになる条件を記述することにより条件に応じてEXWORKをONさせることが可能です。

  • PLCの編集方法はPLCシステム説明書を参照してください。
②I/O基板の配線で対応

汎用I/Oに割り付けて外部ワーク座標オフセット有効にします。

「データバンク」→「外部入出力信号」→「外部入力信号」で右の画面が表示されます。

空いている入力端子台の入力に「509」を入力します。入力すると該当する端子番号の信号名に「EXWORK」と表示されます。

設定した端子番号に入力信号がONするように配線を行います。

外部入力信号 画面
  • ※配線に関しては「設置説明書:第五章 外部入出力信号」を参照し実施してください。
  • ※配線作業は電気の知識がある人が実施してください。
PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-008

容量の大きなプログラムを動かしたい

メモリ運転出来ない容量の大きなプログラムを動かす方法は2つあります。

  1. 拡張メモリ運転(通常のメモリ運転のままテープ運転するイメージ)
  2. テープ運転(外部からプログラムを入力しながら運転)
  • ※メモリ運転とテープ運転は選択式です。
    選択はユーザパラメータ/スイッチ1 003 メモリ運転選択で行います。
拡張メモリ運転

メモリ運転でプログラムを選択したときNCがプログラムサイズを判断してメモリ運転から拡張メモリ運転に変えます。
プログラムは本機の残メモリ容量を超えなければ入力できます。

拡張メモリ運転 画面
  • 容量が設定値より大きなプログラムをメモリ運転すると、拡張メモリ運転に変わります。
    画面左上に拡張メモリ運転と表示します。
  • メモリ運転はプログラムサイズが2Mを超えると拡張メモリ運転になります。
    プログラムサイズはパラメータ変更で8Mも選択出来ます。
プログラム一覧詳細 画面

プログラム編集キー→プログラム編集
メモリの残容量は画面右下に表示しています。

通常のメモリ運転同様に、プログラムをカーソルで選択、またはプログラム番号を入力して起動スイッチで運転を開始します。
そのさい画面上部にメモリ運転ではなく拡張メモリ運転と表示します。

テープ運転

本機へプログラムを入力せず外部装置(一般通信装置、USB)からプログラムを入力しながら動かします。 使用する外部装置に合わせた接続先の設定が必要です。

接続先の設定

一般通信装置でのテープ運転は接続先を一般通信装置に設定します。
USBメモリでのテープ運転は接続先をメモリカードに設定します。
ユーザパラメータ/スイッチ1 003 メモリ運転選択を 1:テープ運転に設定します。

接続先の設定手順(USB)

①

外部入出力メニュー 画面

②

プログラム(外部入出力) 画面

③

接続先切り替え 画面
  • プログラム編集→外部入出力→≫キー→F2キーで接続先切り換えが表示されます。
  • 数字キーの入力で選択EOBキーで変更が完了します。
  • USBは2を入力します。
テープ運転への切り換え手順
スイッチ1 画面

ユーザパラメータ/スイッチ1 003メモリ運転選択 を 1:テープ運転 に設定します。

テープ運転開始手順

①

プログラム一覧 画面

②

テープ運転(メモリカード) 画面

テープ運転へ切りかえ後メモリ運転モードに切りかえるとUSB内容が表示されます。
起動するプログラムを選択またはプログラム番号を入力設定キーを押し起動スイッチでスタートします。

PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-009

プログラムの途中から動作させたい(CNC-C00)

プログラム再開機能をユーザパラメータで2つのタイプから任意で選択します。

再開機能の選択

ユーザパラメータ/スイッチ1/18 プログラム再開機能で選択します。
0:タイプ1
1:タイプ2
設定の変更は0or1の数値で選択します。

プログラム再開機能(タイプ1)

再開位置の指定は2通りの方法があります。

  1. F1キー(プログラム再開)を押し再開するシーケンス番号を入力しEOBキーを押します
  2. カーソルキーで実行ポインタを再開位置まで移動します
    どちらの場合も再開位置まで実行した状態から始まります。
    メモリ運転 画面

    開始するシーケンス番号を入力し、EOBキーを押します。

    • ※タイプ1,2ともプログラムの実行は通常の起動と同じく起動スイッチで行います。
プログラム再開機能(タイプ2)

直前まで実行した状態から再開するリスタートと、再開位置直前までを読み飛ばした状態で再開するシーケンスサーチの2通りの再開方法を選択可能です。

  1. ①読み飛ばす場合
    1. F0キー(シーケンスサーチ)を押しシーケンス番号を入力します。
    2. シーケンスサーチもプログラム再開も選択せず、カーソルキーで実行ポインタを再開位置まで移動します。
  2. ②読み飛ばさない場合の再開方法(リスタート)
    1. F1キー(プログラム再開)を押しシーケンス番号を入力してEOBキーを押します。
メモリ運転 画面
  1. ①シーケンスサーチ
    再開ブロックより前は読み飛ばします。
  2. ②リスタート
    読み飛ばしなしで再開。
PDFで見る(PDF 0.1MB)PDFのアイコン

ncp-010

パソコンでNC言語のプログラム作成をしたい

Windowsならメモ帳でプログラムを作成出来ます。

1ブロック入力ごとに⏎(エンターキー)を押します。
エンターキーの箇所はNCへ入力すると;(エンドオブブロック)になります。
M30のブロックにも忘れずエンターキーを押して下さい。

メモ帳 画面

プログラムのファイル名をO(オー)+4桁の数字で保存します。(O0001等)

「.txt」より前がファイル名になります。
ここへ「例)O0001」を入力して保存します。

名前を付けて保存 画面

コメントに日本語を使ったら保存するときに文字コードを「UTF-8」から「ANSI」に変更します。

クリックして文字コードを選択します。

名前を付けて保存 画面

保存したプログラムは拡張子が「.txt」になっているので「.nc」へ変更します。

拡張子が「.txt」のファイル

拡張子を変更すると図のようなメッセージが出ます。
「はい」で問題ありません。

名前の変更 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-011

ワーク座標原点のZ座標の計測方法を知りたい

    ※相対座標位置は表示する座標値を任意の値へ変更することが出来ます。
    この機能を使いテーブル上面からの原点設定位置までの高さを測って、ワーク座標原点Zを設定出来ます。
測定に必要な道具
  1. タッチプローブ(タッチ信号を入力出来ない物で可)
  2. 100.0のゲージ(Z軸最上点が480.0の場合)
測定完了までの手順
  1. ゲージをテーブル上面に置きます。
  2. ゲージの上面をタッチプローブで測ります。
  3. ゲージ上面を測った位置で相対座標位置のZ軸を100.0に設定します。
  4. ワーク座標原点Zの位置をタッチプローブで測ります。
  5. 相対座標位置Zの値をメモします。
  6. ワーク座標原点Zへ手順5でメモした値を入力します。
測定の手順
  1. ゲージをテーブル上面に置きます。
    テーブルとゲージの底面にゴミ、盛り上がりの傷が無い事を確認してから置きます。
  2. ゲージの上面をタッチプローブで測ります。
    倍率をx10にしてゲージ上面へタッチプローブをZ軸マイナス方向へゆっくり下ろしていき、タッチした位置で止めます。
    ゲージ上面
    1. ①100.0mmゲージ
  3. ゲージ上面を測った位置で相対座標位置のZ軸を100.0で設定します。
    • 位置キーを押します。
    • F7キー(カウンタリセット)を押します。
    • 青いカーソルが出現するので、↓キーを使いZ軸にカーソルを合わせます。
    • リセット値を100.0と入力、EOBキーを押します。
    カウンタリセット 画面
    1. ①F7キーを押す
    2. ②カーソルをZに
    カウンタリセット 画面
    1. ③100.0と入力
    カウンタリセット 画面
    1. ④EOBキーを押すとZが100.0と表示
  4. ワーク座標原点Zの位置をタッチプローブで測ります。
    Z軸原点とする位置にタッチプローブをZ軸マイナス方向へゆっくり下ろしていき、タッチしたら止めます。
    Z軸原点位置
    1. ①Z軸原点位置
  5. 相対座標位置Zの値をメモします。
    タッチした位置で止めた相対座標位置Zの値をメモします。
    メモした値がワーク座標原点Zの入力値です。
    • ※相対座標位置の値をワーク座標原点に直接入力は出来ません。
    現在位置 画面
    1. ①ワーク座標原点Zの入力値
  6. ワーク座標原点Zへ手順5でメモした値を入力して完了です。
    先ほどメモしたZの値をデータバンク/ワーク座標原点へ入力します。
    使用するワーク座標のZへメモした数値を入力して下さい。

以上の手順でワーク座標原点Zの設定が完了しました。

PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-012

クーラントオフのとき、加工プログラムが起動されないようにしたい(CNC-D00)

ユーザパラメータの設定により実現可能です。

データバンクメニュー→ユーザパラメータ→スイッチ1→運転で以下の画面を表示させ、「クーラントポンプ起動前チェック」を<有効>に設定します。

<有効>に設定すると、加工プログラム起動時に【クーラントポンプ】キーがオフである場合、アラーム<<SM4119 クーラントポンプ オフ>>が発生します。

スイッチ1(運転) 画面

クーラントオフ起動前チェックがオフの場合でも、内蔵PLCとマクロを組み合わせることで同様の機能を実現することも可能です。

下記に例を示します。

【内蔵PLC】

クーラント(もしくはクーラントSW)がONしたときにマクロ変数がONする回路を組みます 下記例はマクロ変数#1000を使っていますが任意の変数でOKです。

回路 例
【NCプログラム】

(O1001)
IF[#1000 EQ 1] GOTO 1000
(アラーム処理)
#3000=1(COOLANT ERR) ←クーラントがOFFの場合はアラーム停止させる
N1000
(通常処理)
M30

PDFで見る(PDF 0.3MB)PDFのアイコン

ncp-013

プログラムの途中から動作させたい(CNC-D00)

プログラム再開機能を用いることで途中からの動作が可能です。
再開機能には2つのタイプがあり、ユーザパラメータにより選択可能です。

再開機能のタイプ選択

データバンクメニューから<5.ユーザパラメータ> - <1.スイッチ1> - <運転>を選択します。

タイプ1

直前までのプログラムを実行した状態で再開します。
プログラム先頭からの命令を読み込むため、直前のモーダル状態を反映します。

タイプ2

直前までのプログラムを読み飛ばした状態で指定した箇所からプログラムを再開するシーケンスサーチが選択可能になります。

  • ※タイプ2は指定した箇所までのモーダル情報は一切読み込まないので十分注意してください
プログラム再開 シーケンスサーチ
タイプ1 ○ ×
タイプ2 ○※ ○
  • ※カーソル操作不可
スイッチ1(運転) 画面
プログラム再開機能 (タイプ1)
I.シーケンス番号を入力して再開する箇所を指定する方法
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②<プログラム再開>を押します。
  3. ③再開したい箇所のシーケンス番号を入力し、EOBボタンを押します。
    例) : シーケンス番号10から再開する場合
    →「10」と入力
  4. ④起動ボタンを押すことで、指定した箇所からプログラムが動作します。
プログラム再開
入力窓
Ⅱ.ブロック番号 (プログラムの行数) を入力して再開する箇所を指定する方法
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②<プログラム再開>を押します。
  3. ③再開したい箇所のブロック番号 (行数) の前に「B」を付けて入力し、EOBボタンを押します。
    例) : プログラムのの30行目から再開する場合
    →「B30」と入力
  4. ④起動ボタンを押すことで、指定した箇所からプログラムが動作します。
プログラム再開
入力窓
Ⅲ.カーソルキーで再開する箇所を指定する方法
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②上下のカーソルキーを用いて、緑色の実行ポインタを再開する箇所まで移動させます。
  3. ③起動ボタンを押すことで、指定した箇所からプログラムが動作します。
メモリ運転 画面
プログラム再開機能 (タイプ2)
1.直前までのプログラムを実行した状態で再開する場合
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②<プログラム再開>を押し、再開する箇所を入力した後、起動ボタンを押すことで、指定した箇所からプログラムが動作します。
    • ※入力方法はタイプ1のⅠⅡと同様に、シーケンス番号を指定する場合は数字をそのまま入力し、ブロック番号を指定する場合は数字の前に「B」を付けて入力する。
プログラム再開
2.直前までのプログラムを読み飛ばした状態で再開する場合
I.シーケンス番号を入力して再開する箇所を指定する方法
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②<シーケンスサーチ>を押します。
  3. ③再開したい箇所のシーケンス番号を入力し、EOBボタンを押します。
    例): シーケンス番号10から再開する場合
    →「10」と入力
  4. ④起動ボタンを押すことで、指定した箇所からプログラムが動作します。
シーケンスサーチ
シーケンスサーチ 入力窓
Ⅱ.ブロック番号 (プログラムの行数) を入力して再開する箇所を指定する方法
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②<シーケンスサーチ>を押します。
  3. ③再開したい箇所のブロック番号 (行数) の前に「B」を付けて入力し、EOBボタンを押します。
    例): プログラムの30行目から再開する場合
    →「B30」と入力
  4. ④起動ボタンを押すことで、指定した箇所からプログラムが動作します。
シーケンスサーチ
シーケンスサーチ 入力窓
Ⅲ.カーソルキーで再開する箇所を指定する方法
  1. ①【メモリ運転】キーが押された状態でプログラムメニューを開き、実行するプログラムを選択します。
  2. ②上下のカーソルキーを用いて、緑色の実行ポインタを再開する箇所まで移動させます。
  3. ③起動ボタンを押すことで、指定した箇所からプログラムが動作します。
メモリ運転 画面
PDFで見る(PDF 0.6MB)PDFのアイコン

ncp-014

レファレンス点復帰指令時の座標を変えたい(CNC-C00)

指令するGコードに応じたリファレンス点を変更します。
(G28の場合)

指令形式 G28 X_Y_Z_A_B_C
G28はレファレンス点へ復帰をする際に指令します。

(G30の場合)

指令形式 G30 P_X_Y_Z_A_B_C_

  • P2:第2レファレンス点への復帰
  • P3:第3レファレンス点への復帰
  • P4:第4レファレンス点への復帰
  • P5:第5レファレンス点への復帰
  • P6:第6レファレンス点への復帰

G30は、第2~第6レファレンス点へ復帰する際に指令します。
Pを省略すると、第2レファレンス点への復帰とみなします。
Pを指定すると指定されたレファレンス点への復帰をします。

レファレンス点変更手順
  1. データバンクキーを押します。
  2. F4キー(5.ユーザパラメータ)を押します。
  3. F4キー(4.レファレンス点/対話原点)を押します。
  4. 下記の画面で任意のレファレンス点にカーソルを合わせ、値を入力してください。
レファレンス点/対話原点 画面
PDFで見る(PDF 0.2MB)PDFのアイコン

ncp-015

レファレンス点復帰指令時の座標を変えたい(CNC-D00)

指令するGコードに応じたリファレンス点を変更します。
(G28の場合)

指令形式 G28 X_Y_Z_A_B_C
G28はレファレンス点へ復帰をする際に指令します。

(G30の場合)

指令形式 G30 P_X_Y_Z_A_B_C_

  • P2:第2レファレンス点への復帰
  • P3:第3レファレンス点への復帰
  • P4:第4レファレンス点への復帰
  • P5:第5レファレンス点への復帰
  • P6:第6レファレンス点への復帰

G30は、第2~第6レファレンス点へ復帰する際に指令します。
Pを省略すると、第2レファレンス点への復帰とみなします。
Pを指定すると指定されたレファレンス点への復帰をします。

レファレンス点変更手順
  1. 「データバンク」→「5. ユーザーパラメータ」→「4. レファレンス点/対話原点」で下記画面に移動します。
  2. 各リファレンス点の項目に、任意の座標を入力してください。
  3. 入力後、設定「EOB」キーを押すと入力結果が反映されます。
  4. ▽を押すことでレファレンス点~第6レファレンス点の座標を設定できます。
  5. 入力後は「終了モード」→「保存して終了」を押してください。

レファレンス点/対話原点 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

対話プログラミング

v-001

対話言語でCTS(センタースルークーラント)を設定

クーラントON/OFFの様に非切削系の工程では用意されていません。このため工具割当画面での設定が必要です。

割当画面で切削前補助機能/切削後補助機能へON/OFFの設定をします。

  • センタースルークーラント ON:494
  • センタースルークーラント OFF:495
工具の割当画面
工具の割当 画面

①割当画面で切削前補助機能へカーソルを合わせ、494(センタースルークーラントON)を入力しEOBキーを押します。

工具の割当 画面

②入力した数値はここへ入ります。

工具の割当 画面

③割当画面で切削後補助機能へカーソルを合わせ、495(センタースルークーラントOFF)を入力しEOBキーを押します。

工具の割当 画面

CTSを使用する工具すべてに同じ補助機能を設定します。

補足 工具の割り当て画面までの手順
手動条件 画面

①プログラム編集キーを押す

プログラム編集メニュー 画面

②F5(運転準備)キーを押す

プログラム一覧詳細 画面

③割当を行うプログラムを選択

運転準備メニュー 画面

④F1(工具の割当)キーを押す

工具の割当 画面

工具の割当画面

カーソルキーでブルーバーを

  • 切削前補助機能
  • 切削後補助機能

に合わせて 数値を入力する

PDFで見る(PDF 0.6MB)PDFのアイコン

v-002

対話言語でドリルのステップ加工を設定する

CTSを使用しない深穴を加工する場合に使用します。

対話言語の工具条件以外の切削条件パラメータにて設定を行います。

プログラム編集画面

プログラム編集メニュー 画面
  1. ①F4(切削条件)キーを押す

プログラム一覧画面

プログラム一覧 画面
  1. ②ステップ加工を設定するプログラムを選択する

切削条件画面

切削条件1(穴工具) 画面
  1. ③F4(切削条件3 工具条件以外)キーを押す

切削条件3(工具条件以外)画面

切削条件3(工具条件以外) 画面
  1. ④この画面で、「ドリルステップ方法」「ドリルステップ比率」「ドリルステップ復帰位置」「ドリルステップ戻り量」の4か所を設定する
  1. ❶ドリルステップ方法
    減衰ステップと一定の違い
    一定:一定のドリルステップ切り込み量で加工
    減衰:ドリルステップ切り込み量が小さくなっていく加工(切り込み量は切り込み係数で計算されます。)
  2. ❷ドリルステップ比率

    ドリルステップ比率は工具径に対する割合(%)です。
    1ステップの切り込み量は、ドリル径xドリルステップ比率/100になります。

    例)φ10.0ドリルでステップ比率20%の場合
      (φ)10.0x20(%)/100=2.0
      一回の切り込みは2.0mmになります。

    注意)
    プログラム毎に設定するため、他のドリルでは20%ではなく30%にするという事は出来ません。

  3. ❸ドリルステップ復帰位置
    切削条件3(工具条件以外)(ヘルプ) 画面

    ドリルステップ復帰位置で「0」を選択した場合

    ドリルステップ戻り量は設定不要です。
    F0(終了モード)キーを押します。
    もう一度F0(終了モード)キーを押します。


    *ドリルステップ復帰位置で「1」を選択した場合

    F0キーを押す前に以下の設定もして下さい。

  4. ❹ドリルステップ戻り量
    切削条件3(工具条件以外)(ヘルプ) 画面

    戻り位置を選択した時の戻り量を設定します。

カーソルキーを設定項目に合わせた状態でヘルプキーを押すと詳細解説が表示されます

切削条件3(工具条件以外) 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

対話-Gコード変換

vtr-001

対話→Gコード変換しNCプログラミングで加工する場合、工具データは入力し直しになるか

  • 工具長オフセット、工具径補正、摩耗補正がGコード変換時にNC言語で入力されます。
  • 変換時に入力するにはユーザパラメータ/スイッチ1で設定を行います。
    スイッチ1の115 工具データ変換を1:する に設定してください。
スイッチ1 画面
Gコード変換したNCプログラム
編集画面

①工具長補正入力ブロック

TOOL LENG OFFSET DATA

  • L10:工具長補正(工具データの補正量を出力します)
  • L11:工具長摩耗補正(0を出力します)
  • L13:工具径摩耗補正(0を出力します)
  • プログラム中で使用する工具のデータをGコードで出力するパラメータの設定をしている場合、Gコード変換時に一緒に出力されます。
  • 対話とNC言語では工具データが違うため、出力される工具データは工具長オフセット/工具長摩耗補正 、工具径補正/工具径摩耗補正がGコードで出力され、プログラム実行時に工具データに入力されます。
  • 摩耗補正は0を出力、工具径補正は補正を使うブロックにG10で入力されます。
  • 工具寿命は出力されないため必要があれば設定して下さい。
  • ワーク座標系はユーザパラメータの加工原点変換コードで選択したコードで出力されます。
PDFで見る(PDF 0.1MB)PDFのアイコン

vtr-002

対話↔NCの切り換え方法(CNC-C00)

相互の切り換えはユーザパラメータで行います。

  1. データバンクキーを押します。
  2. F4キー(ユーザパラメータ)を押します。
  3. F1キー(スイッチ1)を押します。
  4. スイッチ1/301 対話/NC言語切換 をNCから対話なら0:対話に
    対話からNCなら1:NCを入力します。
  5. F0キー(終了モード)を2回押します。
  6. リセットキーを押して完了です。
スイッチ1 画面

①ユーザパラメータ/スイッチ1

0301 対話への言語切換

青いカーソルを0301へ移動すると入力欄に対話/NC言語切換と表示されます。
0を入力で対話・1を入力でNC言語へ切り換わります。
入力後EOBキーを押し、その後F0キー(終了モード)を押し、続けてF0キー(編集終了)を押して操作を完了します。

PDFで見る(PDF 0.1MB)PDFのアイコン

vtr-003

対話-NCの言語切替をしたい(CNC-D00)

ユーザパラメータで設定します。

ホームキーを押してメニューを表示させて「データバンク」の「スイッチ1」を選択します。

ユーザパラメータ 画面

スイッチ1の画面に遷移したら▶を押してメニュー画面を遷移させて
システムを選択します。そうすると対話/NC言語切替画面が出ます。

スイッチ1(システム) 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

パラメータ

p-001

QT機でパレットにプログラムを設定したい

パレット選択キーを使用し、パレットの連動をしながら加工を行う場合、各パレットで使用するプログラムを設定します。
設定はユーザパラメータで行います。

手動条件画面

手動条件画面
  1. ①データバンクキーを押す

データバンクメニュー

データバンクメニュー 画面
  1. ②ユーザパラメータ(F4)を押す。
    (対話言語の場合はF5)
スイッチ1 画面
  1. ③「>>」キーを押してファンクションを切り替え
スイッチ1 画面
  1. ④F2(クイックテーブル)キーを押します

クイックテーブル画面

クイックテーブル 画面

3001番

プログラムのあるフォルダを設定します。フォルダに入れていない場合は空欄にしてください。

3002番

パレット1側のプログラムを設定

3003番

パレット2側のプログラムを設定

両方のパレットを使う場合、プログラムは同じフォルダへ入れてください。

補足 NC言語と対話言語のパラメータ画面
NC言語
クイックテーブル 画面

NC言語

3001へフォルダを設定します。
3002へパレット1のプログラム番号を設定します。
3003へパレット2のプログラム番号を設定します。

対話言語
クイックテーブル 画面

対話

3004へフォルダを設定します。
3005へパレット1のプログラム番号を設定します。
3006へパレット2のプログラム番号を設定します。

PDFで見る(PDF 0.4MB)PDFのアイコン

p-002

早送りオーバーライド速度を変更したい

ユーザーパラメータで変更可能です。

「データバンク」→「ユーザパラメータ」→「スイッチ2」

0538~0541の値を変更します。100%の速度は「50000mm/分」になります。

スイッチ2 画面
PDFで見る(PDF 0.2MB)PDFのアイコン

p-003

テーブル積載質量の測定方法を知りたい(CNC-C00)

入出力機能の中に測定機能があります。

テーブル移動の機種は、早送り時に自動で積載質量を推定し、入力画面ストレーブ状態1の"推定結果"に表示します。

推定条件

移動距離は200mm以上で行うようにしてください。

「入出力画面」→「入出力メニュー:F1」→「ストレーブ状態:F3(ストレーブ状態1)」
でページキーで上下させて下記画面を表示します。

入出力(ストレーブ状態表示) 画面
  • ※任意に測定したい場合は、早送りでX,Yをフルストローク動かすプログラムを作成し早送りオーバーライドを100%で実施することにより推定結果を表示されます。
PDFで見る(PDF 0.2MB)PDFのアイコン

p-004

テーブル積載質量の測定方法を知りたい(CNC-D00)

サポートアプリに本機能を搭載しています。

テーブルを早送り動作で一定の距離を動かすことでテーブル積載質量を推定します。

「サポートアプリ一覧」→「加工パラメータ調整」→「積載質量設定」→「テーブル積載質量設定」→「質量推定」で下記画面を表示します。

左赤枠の操作手順に従って推定を行ってください。

加工パラメータ調整(質量推定) 画面
PDFで見る(PDF 0.4MB)PDFのアイコン

操作、表示

disp-001

機械の日付時刻を変更したい(CNC-C00)

ユーザーパラメータで変更可能です。

「データバンク」→「ユーザパラメータ」→「スイッチ1」

0303:日付 2022年2月1日の場合「22020201」と入力します。
0304:時刻 15時ちょうどに合わせたい場合「150000」と入力します。

スイッチ1 画面
PDFで見る(PDF 0.3MB)PDFのアイコン

disp-002

外部エラーを日本語で表示させたい

外部入出力信号のファイルをPCで編集します。

対応機種はCNC-C制御以降、SPEEIO以降の機種

  • ※CNC-B制御以前(例 TC-S2*)は対応していません

「プログラム編集」→「外部入出力」→「データバンク」を選択して、外部入出力信号をUSBに出力します。
PCで「EXIO.NC」ファイルを開きコメント欄を編集します。

エラー文編集 画面

PCで編集後、EXIO.NCファイルをNCに入力します。
コメント欄に入力した内容が反映されます。

外部アラーム 画面
PDFで見る(PDF 0.2MB)PDFのアイコン

disp-003

オーバーライドスイッチを100%以外にしたときの主軸回転数/送り速度を表示させたい

メモリ運転時にオーバライドスイッチを操作した場合、表示する画面を切り換える事で確認出来ます。
現在位置で表示される回転数と送り速度が今現在機械が実行中の回転数と送り速度の表示です。
画面の切換えは表示中の画面により操作が変わります。

  • ※プログラムだけを表示している場合
    位置キーを押します。
    表示された画面の主軸回転数と送り速度が現在の値です。
  • ※モーダル1を表示している場合
    F0キー(現在位置)を押します。
    表示された画面の主軸回転数と送り速度が現在の値です。
    プログラム実行中の主軸回転数や送り速度は位置キーを押した画面で表示します。
現在位置
現在位置 画面

位置キーを押すとこの画面になります。

主軸回転数

主軸の回転速度を表示

送り速度

軸の送り速度を表示

モーダル1
モーダル情報1 画面

位置キーを押したあとF1キー(モーダル1)を押すとこの画面になります。

主軸回転数

プログラムで指令した回転数を表示

送り速度

プログラムで指令した軸の送り速度を表示

PDFで見る(PDF 0.1MB)PDFのアイコン

disp-004

機械の日付変更をしたい(CNC-D00)

ユーザパラメータで設定します。

ホームキーを押してメニューを表示させて「データバンク」の「スイッチ1」を選択します。

ユーザパラメータ 画面

スイッチ1の画面に遷移したら▶を押してメニュー画面を遷移させてシステムを選択します。
そうすると現在日付時間の変更メニューが出ます。

スイッチ1(システム) 画面

日付・・・2022年2月1日の場合「22020201」と入力します。
時刻・・・15時ちょうどに合わせたい場合「150000」と入力します。

PDFで見る(PDF 0.3MB)PDFのアイコン

disp-005

機械を立ち上げるとアラーム復旧画面が表示されるのを解消したい

機械の電源を入れると復旧画面が表示されるときはリセットキーを押して画面をリセットしてください。
復旧画面はリセットで解除できます。

毎回リセットをしたくない場合は、復旧画面でF0キー(現在アラーム)を押してからリセットしてください。
次の電源投入から復旧画面が表示されなくなります。

復旧画面
アラーム/オペレータメッセージ復旧 画面

F0キーを押すと現在アラームが選択されます。
画面が切り変わったらリセットキーを押し操作を完了します。

PDFで見る(PDF 0.1MB)PDFのアイコン

disp-006

図形機能(描画)の設定と使い方

描画機能は運転描画と工具軌跡シミュレーションの2つのモードがあります。
運転描画の使い方の説明となります。

運転描画を動かす手順

メモリ運転モードにしてから、描画キーを押して下さい。
メモリ運転モード以外の状態で描画キーを押した場合、描画を動かせません。

始めて運転描画を使う場合は描画設定の変更を行ってください。
各々の設定値は下図の通り設定して下さい。

F3キー(描画設定)を押し設定値を変更します

運転描画(描画設定) 画面

ページキーを押して次のページに切り換え設定の変更をします。

運転描画(描画設定) 画面

描画設定が完了したらサイクル描画起動を押す前に一括設定をします。

一括設定の手順
運転描画(描画設定) 画面
  1. ①変更が必要な描画設定を終了したらF5キー(一括設定)を押します。
運転描画(描画設定) 画面
  1. ②F0キー(はい)を押します。
運転描画(描画設定) 画面
  1. ③F0キー(確定)を押します。
    以上で一括設定を完了します。
運転描画 画面
  1. ④F0キー(サイクル起動)を押し描画を開始します。
サイクル起動後の描画について

描画の軌跡が表示されなかったり、描画の軌跡が画面からはみ出てしまう場合は、描画の位置(オートスケール)や描画のサイズを調整(拡大/縮小)します。

オートスケール
運転描画 画面

F2キー(ズーム)を押します。
画面下のメニューが切り変わります。

運転描画(ズーム) 画面

F5キー(オートスケール)を押して下さい。
F5キーを押すとプログラムの先頭から最後まで通しで動きます。
オートスケールを終えてからサイクル描画起動すると、画面に収まるサイズで軌跡を描画します。

描画サイズの拡大/縮小
運転描画(ズーム) 画面
  1. ①拡大
  2. ②縮小

描画サイズは拡大と縮小を使い調整します。
F1キー(拡大)でサイズを大きく、F2キー(縮小)でサイズを小さくします。

運転描画(ズーム) 画面
  1. ①描画位置の印
  2. ②描画サイズの赤い枠

F1キー(拡大)かF2キー(縮小)を押すと赤い枠が表示されます。
赤い枠が拡大/縮小の範囲となります。
赤い枠の中心にある□は範囲の中心を表しています。
描画位置はこの□を画面の中心に来るようにカーソルキーで調整します。
拡大/縮小の範囲は、F1キー/F2キーを押す回数で調整します。
範囲を決めたらF0キー(確定)を押します。

描画サイズを拡大したい場合はズームを押し、F1キー(拡大)を押すと赤い枠が出ます。
更にF1キーを押す度に枠が狭くなりF0キー(確定)で範囲が確定となり、赤枠範囲を拡大表示します。
縮小の場合も同じ手順で行います。

PDFで見る(PDF 0.3MB)PDFのアイコン

disp-007

描画の速度を上げたい(CNC-C00)

描画の画面でF3キー(描画設定)を押すと設定画面が開きます。
描画速度に関する3つの設定があるので、全て変更します。
各々の設定値の説明は機上でも確認出来ます。
設定値が分からない場合、参考の設定値を入力して下さい。

  1. 描画速度
    描画速度1を描画速度2で10等分した速さを1~10で指定します。
    速度の指定は1が最も遅く10に近づくほど描画が速くなります。
    描画速度1と2の設定値を描画速度1≦描画速度2とした場合、設定値を変えても描画の速さが変わりません。
    運転描画(描画設定) 画面
  2. 描画速度1
    画面の対角を描画する最長時間を設定します。
    設定範囲は0.1から99.9、描画速度2より大きな値を設定します。
    運転描画(描画設定) 画面
    • ※参考の設定値は1.0です。
  3. 描画速度2
    画面の対角を描画する最短時間を設定します。
    設定範囲は0.1から99.9、描画速度1より小さな値を設定します。
    運転描画(描画設定) 画面
    • ※参考の設定値は0.1です。

3つの設定値を変更したらF0キー(確定)を押して下さい。
元の画面に戻ったらF0キー(サイクル描画起動)を押すと設定した速度で描画します。

PDFで見る(PDF 0.1MB)PDFのアイコン

disp-008

ワークカウンタの使い方を知りたい

ワークカウンタを使うにはMコードの入力と生産モニタでカウンタの設定が必要です。

  1. プログラム中でカウンタ指定のMコードを入力して下さい。
  2. 指定したカウンタの設定を生産モニタで行って下さい。
  • ※M02/M30実行時にカウント数に設定した数値分現在値をカウントアップします。
1.カウンタONのMコード

使用するカウンタに対応したMコードを指令します。

カウンタとMコード

カウンタ1:M211
カウンタ2:M212
カウンタ3:M213
カウンタ4:M214

  • ※カウンタ1~4に機能的な違いは無いので、使用カウンタは任意で決めて下さい。
2.生産モニタ/ワークカウンタの設定

ワークカウンタ1~4のうち、使用するカウンタのパラメータ設定を行います。

カウンタのパラメータ設定 画面
  1. ①カウント数
    プログラム終了(M02/M30)でカウントアップするワークの数を入力します。
    • ※1個加工であれば1を、2個加工であれば2を入力します。
    • ※プログラム終了時に設定した数値分カウントアップします。
      複数個設定の場合でも随時完了した分をカウントアップはしません。
  2. ②現在値
    現在のカウント数を表示します。
    加工が終わるたびに表示する値がカウント数ずつ増えて行きます。
    カウント開始時に0を入力します。
  3. ③終了値
    カウント終了の値を入力します。
    必要個数を入力します。
  4. ④終了予告値
    終了前予告が必要な場合に終了値より小さな値を入力します。
    予告値に到達すると終了/予告の欄に「終了予告中」と表示されます
生産モニタ/ワークカウンタの設定手順
  1. 生産モニタキーを押します。
  2. 1.ワークカウンタを選択します。
    選択は「1」を入力後EOBキーを押す、またはF1キーを押します。
  3. カウント数を入力します。
    現在値の表示がカウントアップごとに増える値です。
    1回1アップであれば1を、2アップであれば2を入力します。
    • ※0を入力するとカウントしません。
  4. 現在値を入力します。
    カウント開始時の現在値を入力します。
    0スタートであれば0を、途中からであればその開始の値を入力します。
  5. 終了値を入力します。
    カウント終了の値を入力します。
    最大値は99999です。
  6. 終了予告値を入力します。
    終了予告する値を入力します。
    終了値より小さな値を入力、その値になると画面にメッセージを表示します。

    予告中はカウンタ設定画面の終了/予告へもメッセージが表示されます。

    ワークカウンタ 画面
ワークカウンタ指令のあるプログラムの作成例

G54G90G80G64G00;
M211; ←ワークカウンタ1の指令
G100T01X0Y0Z2.0G43H01M03S1000;
G81R2.0Zー5.0F500K0;
X0Y0;
G80;
G91G28Z0;
G90; ←M30ブロックの実行でカウントアップします。

ワークカウンタを指令するブロックはM30より前であれば何処で指令しても構いません。

PDFで見る(PDF 0.2MB)PDFのアイコン

disp-009

データ保護を有効/無効を切り替えたい(CNC-D00)

液晶画面でメニュー切替することで実現できます。

  1. ①画面左下のランプのマークをタッチします。
画面左下
  1. ②データ保護のメニューが表示されるのでタッチすると切り替わります
データ保護のメニュー

データ保護有効表示

データ保護有効表示(ランプ点灯)

データ保護無効表示

データ保護無効表示(ランプ点灯なし)
PDFで見る(PDF 0.2MB)PDFのアイコン

高精度モード

disp-019

高精度モードBで付加軸移動をさせたい

高精度モードB中は切削送りで付加軸移動が入ると一時的に解除されます。
切削送りで付加軸移動する場合は機械パラメータを変更してください。

機械パラメータ (高精度)
8102 高精度B付加軸 を1:有効 に変更して下さい。

共通メニュー 画面
PDFで見る(PDF 0.1MB)PDFのアイコン

disp-020

切削送り指定を10m/min以上に上げたい

高精度モードBを使うことで最高30mまで指令出来ます。

高精度モードBはMコードで指令します。
M280-M287(レベル1-8)でON、M289でOFFします。
高精度簡単設定では20mまで指令出来ます。

  • ※M280とM281に初期設定値が入っています。
  • ※M282-M287はM281と同じ値が入っています。
    コーナオーバライド等のパラメータは初期設定値では問題があった場合適宜変更して使ってください。
高精度B 画面
PDFで見る(PDF 0.1MB)PDFのアイコン

設置

set-001

1.工場電源の工事をするのに電源の配線容量を知りたい
(S300X1/S500X1/S700X1/S1000X1/M140X1/M140X2/R450X1/R650X1)

機種毎及び主軸の仕様で異なります。以下の表を参照してください。

対象機種:S300X1/S500X1/S700X1/S1000X1

S300X1/S500X1/S700X1/S1000X1の仕様表

対象機種:M140X1/M140X2

M140X1/M140X2の仕様表

対象機種:R450X1/R650X1

R450X1/R650X1の仕様表
使用上の注意
PDFで見る(PDF 0.5MB)PDFのアイコン

set-002

2.工場電源の工事をするのに電源の配線容量を知りたい
(S300X2/S500X2/S700X2/M200X3/M300X3/R450X2/R650X2/F600X1)

機種毎及び主軸の仕様で異なります。以下の表を参照してください。

対象機種:S300X2/S500X2/S700X2

S300X2/S500X2/S700X2の仕様表

対象機種:M200X2/M300X3

M200X2/M300X3の仕様表

対象機種:R450X2/R650X2

R450X2/R650X2の仕様表

対象機種:F600X1

F600X1の仕様表

<全機種共通注意事項>

全機種共通注意事項

電源拡張クミ(オプション)が有りの場合の配線は「設置説明書」の第11章(29)
電源拡張クミを参照してください。

PDFで見る(PDF 0.9MB)PDFのアイコン

set-003

3.工場電源の工事をするのに電源の配線容量を知りたい(W1000Xd1)

主軸の仕様で異なります。以下の表を参照してください。

W1000Xd1の仕様表
分電盤と配線についてのご案内
PDFで見る(PDF 0.4MB)PDFのアイコン

set-004

4.工場電源の工事をするのに電源の配線容量を知りたい
(S300Xd1/S500Xd1/S700Xd1/U500Xd1)

主軸の仕様で異なります。以下の表を参照してください。

S300Xd1/S500Xd1/S700Xd1/U500Xd1の仕様表
分電盤と配線についてのご案内
PDFで見る(PDF 0.5MB)PDFのアイコン

内蔵PLC

plc-001

PLCを編集モードにすると「SL7503:データ保護が有効にされている」が表示される

以下の2項目を確認します。

1.ユーザパラメータの設定を確認します。

「データバンク」→「ユーザパラメータ」→「スイッチ1」→0306:PLCラダープログラム保護[0:無効 1:有効」を無効にします。

2.データ保護スイッチ(オプション)

データ保護スイッチがある機械では、データ保護「無効」を選択します。

PDFで見る(PDF 0.2MB)PDFのアイコン

plc-002

機械本体でのPLC編集方法を知りたい(行挿入、横線の引き方等)

【目次】
  • 横線の削除
  • 空行の挿入
  • 横線の引き方
  • OR回路の削除(縦線削除)
横線の削除方法

横線の削除はカーソルを合わせて削除キーを押すと削除されます。
回路追加時はカーソル位置で接点追加すれば接点が上書きされます。

空行の挿入方法

カーソルを合わせて「シフト」キーと「挿入」キーを同時押します。

横線の引き方

接点回路等を削除した場合は下図のように線が途切れてこのまま変換するとエラーが出ます。

横線の引き方①

上図の位置にカーソルを持って行き「シフト」キーとカーソルの「▶」キーを同時に押します。
これで切れていた部分が横線で繋がりました。

横線の引き方②
MOV命令の入力方法

例として、下図のコイルをMOVに変更する場合

MOV命令の入力方法①

MOVの場合は3つ分使うため1番右から数えて3つ目の位置にカーソルを移動します。 ここで
MOV BDX117 BDY117
と入力します。

MOV命令の入力方法②

回路が書き換わりました。

OR回路の削除(縦線削除)

上記例でBX002にカーソルを合わせて「削除キー」を押すと縦線が残ります。

OR回路の削除(縦線削除)① OR回路の削除(縦線削除)②

縦線を消すためにはカーソルを↓図の位置まで持っていき「F5:縦線削除」を押します。

OR回路の削除(縦線削除)③

縦線削除を実行することにより、カーソル左側の縦線が削除されます。

OR回路の削除(縦線削除)④

さらに上記図の状態で「F5:縦線削除」を実行することにより残った縦線も削除されます。

OR回路の削除(縦線削除)⑤
PDFで見る(PDF 0.3MB)PDFのアイコン

plc-003

機械本体でのPLC編集モードへの入り方がわからない(CNC-D00)

サポートアプリにあります。

ホームキーを押して、サポートアプリ一覧を選択します。

表示画面

PLCを選択します。

サポートアプリ一覧 画面

プログラム構成ユニット編集を選択します。

PLCメニュー 画面

編集するラダーを選択します。

PLC(プログラム構成ユニット(POU)編集) 画面

編集モードを選択することにより編集が可能です。

  • ※編集するにはユーザパラメータでPLC編集可能に設定する必要があります。
PLC(プログラム編集 LD) 画面
PDFで見る(PDF 0.4MB)PDFのアイコン

plc-004

内蔵PLCとパソコンソフトで通信ができない(CNC-C00)

内蔵PLCとパソコンソフトの通信で「BULT IN PLCと交信できません」エラーが発生する場合の対応になります。
LANケーブルの接続とパソコンのIPアドレスをご確認下さい。詳細はPDFで詳しく説明します。

詳しくはこちら(PDF 1.3MB)PDFのアイコン

plc-005

PLCプログラムをUSBに出力したい(CNC-C00)

以下に手順を示します。

「プログラム編集」→「3:外部入出力」→「2:データバンク」を選択します。

データバンク(外部入出力) 画面

カーソルの「▼」を何度か押してラダープログラムにカーソルを合わせます。

データバンク(外部入出力) 画面

ラダープログラムにカーソルを合わせた状態で「1」を入力後に「F2:出力」を押すとUSBにラダープログラムが出力されます。

  • ※USBからNCに入力したい場合は、上記手順で「F1:入力」を押します。
    但し、事前に「ユーザパラメータ」→「スイッチ1」→「306:PLCラダープログラム保護」を「0:無効」に設定しておく必要があります
PDFで見る(PDF 0.2MB)PDFのアイコン

plc-006

PLCプログラムをUSBに出力したい(CNC-D00)

以下に手順を示します。

「プログラム編集」モードにして、タッチパネル上の「プログラム」を選択します。
メニュー選択画面で「外部入出力」→「データバンク」を選択します。

メニュー選択からデータバンク(外部入出力) 画面

データバンクメニューの「PLCプログラム」を選択します。
PLCプログラムを選択した状態で「1」を入力後に「出力」を押すとUSBにラダープログラムが出力されます。

データバンク(外部入出力) 画面
  • ※USBからNCに入力したい場合は、上記手順で「入力」を押します。
    但し、事前に「ユーザパラメータ」→「スイッチ1」→「システム」→「9906:PLCプログラム保護」を「無効」に設定しておく必要があります
PDFで見る(PDF 0.3MB)PDFのアイコン

plc-007

CNC-C00で使用していたPLCプログラムをCNC-D00用に変換したい

C00 プロジェクト変換機能を用いることで変換可能です。

  1. ①<PLC PROGRAMMING SOFTWARE>を起動し、D00プロジェクトを開きます。
  1. ②ツールメニューの<C00 プロジェクト変換>を選択します。
  • ※<C00 プロジェクト変換>が表示されない場合は補助メニューの<オプション設定>を選択し、<カスタム設定>タブ-<C00プロジェクト>-<機能を有効にする>にチェックを入れてください。
D00プロジェクト 画面
  1. ③ <C00プロジェクト変換>ダイアログが表示されるので、C00プロジェクト、変換元プログラム、変換先プログラムを設定します。
    コメントデータを変換する場合や、グローバルOMコメントを変換する場合は当該項目にチェックを入れて、<OK>ボタンを押します。
  • ※変換元のC00のPLCデータは、プロジェクトファイルとして用意してください。
C00プロジェクト変換のダイアログ
  1. ④プロジェクト変換が行われます。
    完了すると右のメッセージが表示されるので、<OK>ボタンを押します。
プロジェクト変換完了後のダイアログ
  • ※変換元のC00プログラムにD00で使用されなくなったOMが含まれる場合、OMの置換が行われ、置換箇所の一覧が表示されます。
C00プロジェクト変換結果のダイアログ
PDFで見る(PDF 0.3MB)PDFのアイコン

plc-008

NC装置 (CNC-D00) から出力したPLCプログラムを編集したい

PLC Programming software D00 EDITORのプロジェクトのインポート機能を用いることで編集可能です。

  1. ①NC装置から出力したファイル (PLCPRJ.bpp) をPCに保存します。
  2. ②<PLC PROGRAMMING SOFTWARE>を起動します。
  1. ③プロジェクトメニューから<プロジェクトの新規作成>を選択します。
プロジェクトメニューから<プロジェクトの新規作成>を選択する画面
  1. ④プログラム選択画面で「D00プロジェクト」を選択します。
プログラム選択画面のダイアログ
  1. ⑤プロジェクト名とプロジェクト保存フォルダを入力します。
プロジェクト名とプロジェクト保存フォルダを入力する画面

<OK>ボタンを押すと右図のようにプロジェクトが作成されます。

プロジェクト作成後の画面
  1. ⑥プロジェクトメニューから<インポート>を選択します。
プロジェクトメニューから<インポート>を選択する画面
  • ※PLC Programming software D00 Editorで開いているプロジェクトが未保存の状態で インポートを実行しようとすると、右のような確認メッセージが発生します。
    インポートを行う場合は<OK>ボタンを押してください。
プロジェクトが未保存の状態でインポートを実行しようとすると、表示されるダイアログ
  1. ⑦インポートファイルを (PLCPRJ.bpp)を選択し、<実行>ボタンを押します。

    インポートが完了すると完了メッセージが表示されます。
インポートファイルを選択する画面
  1. ⑧新規作成したプロジェクト内に、PLCPRJ.bppがインポートされるので、ファイルをダブルクリックで開いて編集することが可能です。
新規作成したプロジェクト内に、PLCPRJ.bppがインポートされた画面
PDFで見る(PDF 0.3MB)PDFのアイコン

plc-009

PCソフトでPLCの2重コイルをチェックする方法(CNC-D00)

以下の手順で実施します。

  1. ①編集ソフトでプロジェクトを開きます
  2. ②編集→二重コイルチェックを選択します。
編集→二重コイルチェックを選択する画面
  1. ③確認メッセージが出るのでOKをクリックするとチェックを開始します。
確認メッセージのダイアログ
  1. ④2重コイルが検出されると以下が表示されます。
2重コイルが検出されると表示される画面
PDFで見る(PDF 0.2MB)PDFのアイコン

plc-010

PC編集ソフトでPLCの実行設定ファイルを変更したい(CNC-D00)

以下の手順で設定可能です。

プログラム実行設定をダブルクリックすることで実行設定画面がポップアップします。

プログラム実行設定をダブルクリックすると表示されるポップアップ

実行設定の有無はプロジェクトツリーで確認できます。

プログラムの前に青いアイコンがあると実行設定されていることを示します。
下記画像の例ではプログラム3は実行設定されていないプログラムになります。

プロジェクトツリーの画面
PDFで見る(PDF 0.2MB)PDFのアイコン

plc-011

NC本体でPLCの実行設定ファイルを変更したい(CNC-D00)

PLCアプリ内の実行/書込み設定で変更できます。

  1. データバンク-ユーザパラメータ-スイッチ1-システムの9906:PLCラダープログラム保護を無効にします。
  2. PLCアプリのPOUユニット編集画面を選択し、「実行設定/書込み設定」を選択します。
PLC(プログラム構成ユニット(POU)編集) 画面

動作させたいプログラムを選択し「書込み実行」を選択します。

プログラム選択 画面
PDFで見る(PDF 0.2MB)PDFのアイコン

plc-012

PLCをモニターできない(CNC-D00)

モニターモードがグレーアウトしている状態の画面

「モニターモード」がグレーアウトしていてモニターモードに移行できない

該当PLCプログラムの実行設定がされていません。

該当PLCプログラムの実行設定がされていない画面

状態が「RUN」になっていないとPLCプログラムは実行されません。「実行設定/書込み設定」で該当PLCプログラムを実行するように設定変更を実施してください。

PDFで見る(PDF 0.2MB)PDFのアイコン

工具設定

disp-010

ATCへ大径工具を設定したい

ATC工具(詳細)画面

大径工具設定は工具登録で行います。

操作手順
  1. MDI運転キーを押します。
  2. ATC工具キーを押します。
  3. F1キー(工具設定)を押します。
  4. 水色に反転しているカーソルを該工具番号の工具種類へ合わせます。
  5. 大径工具を選択します。
ATC工具(詳細) 画面
  • 大径工具設定をしたマガジンの両隣は工具登録が出来ません。
  • 大径工具が必要無くなったら、設定を標準工具に戻せば登録出 来るようになります。
  • 大径工具設定前に大径工具の両隣若しくは隣に工具登録をして いるとアラームが発生します。
PDFで見る(PDF 0.1MB)PDFのアイコン

disp-011

工具寿命の使い方を知りたい

工具一覧で寿命のカウント単位を3種から選択、ユーザパラメータ/スイッチ1で、カウント方式をアップ/ダウンの2種から選択して使用します。

カウント単位

寿命のカウント単位を1~4の数字で選択します。

  1. カウントしない
    寿命管理をしません。
  2. 時間
    切削送りの累計1分毎にカウントします。
  3. 穴加工数
    NC言語:固定サイクルを使用して加工した穴数をカウントします。
    対話:穴加工をする工程の穴数をカウントします。
  4. プログラム/ワーク数
    プログラム:NC言語で表示する項目です。M30/M02実行時にカウントします。
    ワーク数:対話使用時に表示する項目です。運転終了時に加工に使用した工具の寿命をワーク数分カウントします。

    NC言語の工具一覧

    工具一覧 画面
    1. ①この行にカーソルが来ると寿命単位を選択出来ます。
      単位を選択後、初期寿命/終了寿命を入力します。
    2. ②寿命単位の選択は数値入力でします。

    対話の工具一覧

    工具一覧 画面
    1. ①この行にカーソルが来ると寿命単位を選択出来ます。
      単位を選択後、初期寿命/終了寿命を入力します。
    2. ②寿命単位の選択は数値入力でします。
カウント方式

選択したカウント方式により工具一覧の項目名が変わります。

  • ※初期寿命も終了寿命も工具寿命の最大値を入力します。
カウントダウン方式
  • ユーザパラメータの設定 [0:方式1]
  • 工具一覧の項目名 初期寿命
  • 寿命へ初期寿命と同じ値が入り0になったら寿命おわり
カウントアップ方式
  • ユーザパラメータの設定 [1:方式2]
  • 工具一覧の項目名 終了寿命
  • 寿命へ0が入り終了寿命と同じになったら寿命おわり
スイッチ1 画面

選択する方式の番号を入力します。

工具寿命が終わったら

  • ※工具寿命が終わったことを画面に表示します。
    工具を新品に交換し工具データを更新して下さい。
    工具寿命が切れたままではプログラムの起動が出来ません。
    工具寿命を初期化するか工具データの寿命を直接修正してください。
工具寿命終わり(0901)

↑画面上部に表示されます。

寿命の初期化手順
ATC工具(詳細) 画面
  1. ①F5キー(寿命初期化)を押します。
寿命初期化 画面
  1. ②F2キー(寿命初期化)を押すと寿命が初期化されます。
    工具が複数ある場合は、カーソルを合わせて同じ操作をして下さい。
PDFで見る(PDF 0.2MB)PDFのアイコン

disp-012

登録済みの工具番号を他のマガジン番号へ入れ替えたい

同じ工具番号を重複して登録出来ないため、登録した工具番号を違うマガジン番号へ入れ替える場合は、入れ替える工具番号の登録を解除する必要があります。

登録を解除せず違うマガジン番号へ工具番号を入力するとアラームが発生します。

ATC工具(詳細) 画面

登録を解除していない

ATC工具(詳細) 画面

工具番号が重複するためアラームが発生

登録を解除してから登録したいマガジン番号へ工具番号を入力すると登録出来ます。

ATC工具(詳細) 画面

登録を解除した

ATC工具(詳細) 画面

工具番号が重複しないため登録完了

ATC工具登録を解除する手順

ATC工具登録の解除はMDI運転モードで行います。

  1. MDI運転キーを押します。
  2. ATC工具キーを押します。
  3. F1キー(工具設定)を押します。
  4. 解除する工具番号を登録しているマガジン番号へカーソルを合わせます。
  5. 削除キーを押します。

以上の操作でATC工具登録が解除されます。

ATC工具(詳細) 画面
  1. ①マガジン番号
  2. ②カーソル(水色)パネルのカーソルキーを使って動かせます。
ATC工具登録の手順

MDI運転モードで行います。

  1. MDI運転キーを押します。
  2. ATC工具キーを押します。
  3. F1キー(工具設定)を押します。
    • ※直前に工具番号の登録解除をした場合は、登録手順は4.から行います。
  4. 登録するマガジン番号へカーソルを移動します。
  5. 工具番号を操作パネルの数値キーで入力します。
  6. 操作パネルのEOB/設定キーを押します。

以上の操作で任意のマガジン番号へ工具番号をATC工具登録をします。

例)マガジン番号1にある工具番号1をマガジン番号5へ入れ替えます。

マガジン番号1に登録している工具番号1の登録を解除します。

  1. MDI運転キーを押します。
  2. ATC工具キーを押します。
  3. F1キー(工具設定)を押します。
  4. マガジン番号1へカーソルを移動します。
  5. 削除キーを押します。

次にマガジン番号5へ工具番号1を登録します。

  1. MDI運転キーを押します。
  2. ATC工具キーを押します。
  3. F1キーを押します。
  4. マガジン番号5へカーソルを移動します。
  5. 数値キーで5を入力します。
  6. EOBキーを押します。
PDFで見る(PDF 0.2MB)PDFのアイコン

disp-013

予備工具の設定方法を知りたい(NC言語)

  • ※寿命が切れた工具を同じグループの寿命のある工具と切り換える設定をします。
    工具データで工具寿命と工具グループの設定が必要です。
データバンク/工具データの設定
  1. 工具データで工具長等加工に必要なデータと「工具寿命」の設定をします。
  2. 工具グループで工具グループ番号を設定します。
  3. 設定した工具グループ番号へ同じグループに属する工具を工具番号で登録します。
    • ※グループ番号内に登録した2本目からが予備工具です。
1.工具一覧の設定
工具一覧 画面
  1. ①最初に使う工具
  2. ②工具番号1の予備工具

工具長オフセット、工具径補正(必要な工具のみ)、工具寿命を設定します。
工具寿命に関する設定は4つ有り、上記画像は「回数」で設定しました。

  • ※回数とはプログラムの実行回数のことを指します。
2.グループ番号の設定
工具グループ 画面
  1. ①グループ番号
  2. ②工具番号
  3. ③使用順

グループ番号を01と入力しました。
グループ番号を入力すると画像の様に工具登録画面に変わります。

3.工具番号の登録

工具グループ番号の入力が完了するとこの画面が開きます。
画像ではグループ01に「工具番号1」と「工具番号2」の工具を設定しました。

  • ※入力した順番で工具が使用されます。工具番号の入力は順番に注意して下さい。
ATC工具登録
  1. 予備工具も含め加工に使う全ての工具をマガジンへ登録します。
  2. マガジンへの登録時に工具グループ番号も設定します。
ATC工具(詳細) 画面
  1. ①グループの列
  2. ②水色のカーソル

カーソルキーを使い水色のカーソルをグループ列へ移動しグループ番号を入力します。
上記画像は2本の工具を同じグループへ登録したので、グループ番号は共に01を設定します。

予備工具を使う場合のプログラム指令
  • 工具交換コードの工具番号は工具グループ番号で指令します。
  • 工具長補正/工具径補正も工具交換コードと同じくグループ番号で指令します。
  • ※グループ番号の指令は9+グループ番号を2桁の3桁で指令します。

予備工具を使うプログラム例

メモリ運転 画面

グループ番号で指令

工具グループを使う場合は上記画面のように工具番号・工具長・径補正をグループ番号で指令して下さい。
(径補正は補正量を予備工具ごとに変える必要が無ければ工具番号指令で問題ありません。)
グループの指令は9+グループ番号です。
例のプログラムはグループ01を使っているので、指令は901となります。

プログラム実行中の工具表示
プログラム実行中の画面

プログラム実行時の工具番号(T)はグループ番号を表示します。
工具長補正番号(H)と工具径補正番号(D)は現在使用中の工具番号を表示します。
上記画面では工具番号01の工具データを表示しています。

プログラム実行中の画面

寿命が切れて工具が02番へ変わったため、補正番号と補正量の値が現在使用中の02番へ変わりました。

ATC工具登録画面の表示
ATC工具(詳細) 画面

寿命が切れて予備工具を使用するタイミングで画面上に「予備工具を使用します」と表示します。

ATC工具(詳細) 画面

グループの全ての工具寿命が切れると、「工具寿命終わり」と表示します。

  • ※寿命を初期化するまでプログラムの実行が出来ません。
PDFで見る(PDF 0.2MB)PDFのアイコン

disp-014

予備工具の設定方法を知りたい(対話式)

寿命が切れた工具を予備として設定した寿命の有る工具と交換する機能です。
工具一覧で工具寿命の設定、ATC工具登録で主工具の設定が必要です。

工具寿命を設定する

工具寿命は工具一覧で設定します。
寿命単位の設定は

  1. カウントしない
  2. 時間(分)
  3. 穴加工数(穴)
  4. ワーク数(個)
上記4つから数字で寿命単位を選択後、寿命の値を入力します。

  • ※工具一覧は工具長等の加工に必用なデータの設定も行います。
工具一覧 画面

カウント方式の選択で、初期寿命/終了寿命と表示が変わります。

寿命のカウント方式

表示が初期寿命の場合はカウントダウン方式です。
表示が終了寿命の場合はカウントアップ方式です。
どちらも工具寿命の最大値を入力します。

  • ※カウント方式はユーザパラメータ/スイッチ1で選択します。
    出荷時の設定はカウントダウン方式です。
寿命切れの判定

カウントダウン方式は寿命が0になると寿命切れです。

  • →初期寿命と同じ値が寿命のカウントが進むたび減少していきます。

カウントアップ方式は寿命と終了寿命の値が等しくなると寿命切れです。

  • →0から始まり寿命のカウントが進むたびに増大していきます。

カウントごとの減少/増大する値は寿命単位に従います。

主工具の設定をする

どの工具の予備なのか主工具欄に工具番号で設定します。
画像は工具番号2番を工具番号1番の予備工具として設定しました。

ATC工具(詳細) 画面
  1. ①先に使う工具
  2. ②次に使う工具番号1番の予備工具
  3. ③先に使う工具の工具番号
  4. ④工具の寿命が尽きて新しい工具へ交換後、「寿命初期化」(F5キー)を押します。
    変わった画面で初期化する工具番号にカーソルを合わせ「寿命初期化」(F2キー)を押し初期化します。
ATC工具(詳細) 画面

主工具の寿命が無くなると工具交換のタイミングで「予備工具を使用します」と表示します。

ATC工具(詳細) 画面

全ての工具の寿命が無くなると「工具寿命終わり(0001)」と表示します。
以降は工具寿命を「寿命初期化」をするまでプログラムを起動出来ません。

PDFで見る(PDF 0.2MB)PDFのアイコン

disp-015

工具一覧の工具番号がオレンジ色にならない(CNC-C00)

工具がATC工具に登録されていません。

ATC工具登録方法
  1. ①MDI運転モードにしてください。
  2. ②ATC工具に対象の工具番号を登録してください。
ATC工具(詳細) 画面

「ATC工具」→「工具設定:F1」→「プログラム設定:F0」で上記画面を表示します。

  • カーソルキーで入力したい行まで移動します。(今回は赤枠まで移動しています。)
  • 登録したい工具番号を入力します。(今回は工具番号4の工具を登録しています。)
  • 設定キーを押します。
  • 「プログラム番号設定:F0 」で設定します。
  1. ③登録した工具番号がオレンジ色になっているか確認してください。
工具一覧 画面

「データバンク」→「工具データ:F2」→「工具一覧:F1」

PDFで見る(PDF 0.2MB)PDFのアイコン

disp-016

工具一覧の工具番号がオレンジ色にならない(CNC-D00)

工具がATC工具に登録されていません。

ATC工具登録方法
  1. MDI運転モードを選択します。
  2. 「ATC 工具」→「工具設定」で下記画面に移動します。
  3. 任意の場所にカーソルを合わせ、工具番号を入力して下さい。
  4. 入力後、プログラム設定を押すと結果が反映されます。
ATC工具(詳細) 画面
工具一覧 画面
  1. ①設定した工具番号はオレンジ色になります。
  2. ②設定されていない工具番号は画像のようになります。
PDFで見る(PDF 0.3MB)PDFのアイコン

disp-017

工具長の測定と入力方法を知りたい(CNC-C00)

以下に手動操作で工具長を測定する代表的な手順を示します。
【対象機種】S300/500/700/1000、R450/650のX1、X2 及び F600X1。

  1. ①【手動運転】モードにして、テーブル上にハイトプリセッタを設置します。
ハイトプリセッタ設置 画像

標準仕様の例

ハイトプリセッタ+ブロックゲージ設置 画像

ハイコラム もしくは 低床仕様の例

<注意>

ハイコラム仕様等ではプリセッタを直接テーブル上に置いても工具が届かないので、写真の例のようにブロックゲージ等をテーブル上に置いてその上にプリセッタを置きます。

  1. ② ①で設置したハイトプリセッタの高さを「データバンク-ユーザパラメータ-スイッチ1」の工具長自動設定補正量」に入力します。
    ブロックゲージ等で、かさ上げした場合は、ブロックゲージ+プリセッタの高さを入力し保存終了します。
スイッチ1 画面
  1. ③データバンクメニューの中から工具データ-工具一覧を選択します。
  1. ④測定する工具を選択します。
  1. ⑤手動パルス発生器で工具先端をハイトプリセッタの上方まで移動します。
ハイトプリセッタ+ドリル 画像

ドリルの例

ハイトプリセッタ+フェイスミル 画像

フェイスミルの例

<注意>

上記の写真にあるように必ず刃先がプリセッタの測定面にあたるようにX,Yの位置を手パで移動させてください。

  1. ⑥手動パルス発生器の倍率【X100】で、ゆっくりとZ軸を下げていき、工具先端をハイトプリセッタの測定面高さに合わせます。
  1. ⑦倍率【X10】、【X1】でも⑥と同様の操作を行います。【X1】で工具先端を測定面高さに合わせた状態で次の手順を行います。
操作手順図
  1. ⑧設定する工具番号の「工具長オフセット」欄にカーソルを移動し、<自動設定>[F2]キーを押します。
工具一覧(拡張1) 画面
  1. ⑨自動設定画面の内容を確認し、<はい>[F0]キーを押します。
  • ※工具長自動設定補正量が正しく反映されていることも確認してください。
自動設定 画面
  1. ⑩<終了モード>[F0]キー押下後に、<上書き保存>[F6]キーを押して保存します。
  • ※自動では保存されないので必ず保存操作をしてください。
  1. ⑪設定する工具すべてで④~⑩を繰り返します。
PDFで見る(PDF 0.4MB)PDFのアイコン

disp-018

工具長の測定と入力方法を知りたい(CNC-D00)

以下に手動操作で工具長を測定する代表的な手順を示します。
【対象機種】S300/500/700、R450/650のXd1 W1000Xd1/Xd2

  1. ①【手動運転】モードにして、テーブル上にハイトプリセッタを設置します。
ハイトプリセッタ設置 画像

標準仕様の例

ハイトプリセッタ+ブロックゲージ設置 画像

ハイコラム もしくは 低床仕様の例

<注意>

ハイコラム仕様等ではプリセッタを直接テーブル上に置いても工具が届かないので、写真の例のようにブロックゲージ等をテーブル上に置いてその上にプリセッタを置きます

  1. ② ①で設置したハイトプリセッタの高さを「データバンク-ユーザパラメータ-スイッチ1-データ」の「工具長自動設定補正量」に入力します。
    ブロックゲージ等で、かさ上げした場合は、ブロックゲージ+プリセッタの高さを入力し、保存終了します。

ブロックゲージ等で、かさ上げした場合は、ブロックゲージ+プリセッタの高さを入力し保存終了します。

データ 画面
  1. ③データバンクメニューの中から工具データ-工具一覧を選択します。
  1. ④測定する工具を選択します。
  1. ⑤手動パルス発生器で工具先端をハイトプリセッタの上方まで移動します。
ハイトプリセッタ+ドリル 画像

ドリルの例

ハイトプリセッタ+フェイスミル 画像

フェイスミルの例

<注意>

上記の写真にあるように必ず刃先がプリセッタの測定面にあたるようにX,Yの位置を手パで移動させてください。

  1. ⑥手動パルス発生器の倍率【X100】で、ゆっくりとZ軸を下げていき、工具先端をハイトプリセッタの測定面高さに合わせます。
  1. ⑦倍率【X10】、【X1】でも⑥と同様の操作を行います。【X1】で工具先端を測定面高さに合わせた状態で次の手順を行います。
操作手順図
  1. ⑧設定する工具番号の「工具長オフセット」欄をタッチし<自動設定>を選択します。
工具一覧 画面
  1. ⑨自動設定画面の内容を確認し、<はい>を選択します。
  • ※工具長自動設定補正量が正しく反映されていることも確認してください。
自動設定 画面
  1. ⑩<終了モード>選択後に、<上書き保存>をタッチして保存します。
  • ※自動では保存されないので必ず保存操作をしてください。
  1. ⑪設定する工具すべてで④~⑩を繰り返します。
PDFで見る(PDF 0.4MB)PDFのアイコン

その他

disp-021

機械の図面が必要な場合

製品購入・システム構築に、製品外観図等の図面が必要な場合は最寄りの営業所に連絡をお願いします。

提供できる図面
①外観図

製品の外観寸法とテーブル寸法が表記されています。工場レイアウト等の確認に使用してください。

ファイル形式

  • pdf
  • dxf
外観図(サンプル)
②干渉図

製品のスプラッシュカバー内部テーブルと内壁の距離を表記されています。治具製作・工具長確認に使用してください。

ファイル形式

  • pdf
  • dxf
干渉図(サンプル)
③後部詳細図

機械後部 クーラント落とし口の詳細図面です。クーラントタンクをお客様で作製する場合に参考にしてください。

ファイル形式

  • pdf
  • dxf
後部詳細図(サンプル)
補足 外観図の3Dデータの提供について

自動化システムの検討などで、外観図の3Dデータを要求される場合があります。
この場合も。最寄りの営業所に連絡をお願いします。
機種によってはデータの作成を伴う場合があり、提供に時間がかかる場合もありますので、 ご了承ください。

PDFで見る(PDF 0.3MB)PDFのアイコン

disp-022

機械の塗装色のマンセル番号を知りたい

マンセル番号での塗装は行っていません。

ブラザーの工作機械の塗装はボディ、扉等、全てマンセル番号での色指定はしていません。
外部制作物で塗装色を合わせたい場合は、塗装業者に直接機械を見てもらい、
それぞれの色に合わせて塗装してください。

PDFで見る(PDF 0.1MB)PDFのアイコン

disp-023

推奨クーラントを教えて欲しい

エマルジョンを推奨します。

エマルジョンであればメーカーは問いません。
例としては、ユシロ化学 AP-EX-E5などがあります(2022年1月時点での情報)

ユシローケン AP-EX-E5
PDFで見る(PDF 0.2MB)PDFのアイコン

disp-024

自動電源遮断機能を使いたい

ユーザパラメータで自動電源遮断時刻を設定し、操作パネルの電源を切る機能です。
この時、ブレーカの電源は落ちません。

自動電源遮断時刻は機械が表示する時計の時刻に従います。
機械が表示する時刻と実際の時刻にズレがある場合は、機械の時刻を修正して下さい。

データバンクメニュー 画面

①機械上の時刻はこの位置に表示しています。

機械の時刻はユーザパラメータ/スイッチ1/304 現在時間を修正します。
時刻の修正は何時何分何秒と入力します。

ユーザパラメータ/スイッチ1/304 現在時間

自動電源遮断機能を使うには、

  1. 1. ユーザパラメータ/スイッチ1/105 自動電源遮断機能を1:する を選択して下さい。
    ユーザパラメータ/スイッチ1/105 自動電源遮断機能
  2. 2. ユーザパラメータ/スイッチ1/106 自動電源遮断時刻を設定して下さい。
    ユーザパラメータ/スイッチ1/106 自動電源遮断時刻

自動電源遮断時刻の設定は何時何分何秒を24時間表記で入力します。
例) 午後6:10に電源を落とす設定をする場合の時刻の入力は「181000」と入力します

PDFで見る(PDF 0.1MB)PDFのアイコン

解決しない場合は、下記いずれかの方法でご確認ください。

ユーザー会員向け
ダウンロードサイトで調べる

技術資料や図面データなどのさらに充実した内容をご覧になりたい方は、
ユーザー会員向けダウンロードサイト[新しいウィンドウ]をご利用ください。


説明書AI全検索で調べる

説明書AI全検索

SPEEDIOの説明書に基づいたAIが、操作方法や設定、
トラブル対応などのご質問に対話形式でお答えします。
24時間365日いつでもご利用いただけます。

Webで問い合わせる

お電話でのお問い合わせはつながりにくい場合があります。こちらをご活用ください。


電話で問い合わせる

ブラザー産業機器コールセンター

電話のアイコン0566-25-3710

受付時間についてはこちらをご確認ください。